[指标]火车轨系统指标源码[博易大师公式]


S:=CROSS(CLOSE,EMA(HIGH,30));
X:=CROSS(EMA(LOW,30),CLOSE);
WS:=BARSLAST(S)+1;
WX:=BARSLAST(X)+1;
SS:=CROSS(SUM(S,WX),0.5);
XX:=CROSS(SUM(X,WS),0.5);
STICKLINE(CLOSE>EMA(HIGH,30),EMA(HIGH,30),EMA(LOW,30),1,1),COLORRED;
STICKLINE(CLOSE<EMA(LOW,30),EMA(LOW,30),EMA(HIGH,30),1,1),COLORGREEN;
STICKLINE(CLOSE>EMA(HIGH,150),EMA(HIGH,150),EMA(LOW,150),1,1),COLORMAGENTA;
STICKLINE(CLOSE<EMA(LOW,150),EMA(LOW,150),EMA(HIGH,150),1,1),COLORBLUE;
PARTLINE(CLOSE>EMA(HIGH,30),EMA(HIGH,30)),COLORRED;
PARTLINE(CLOSE<EMA(HIGH,30),EMA(HIGH,30)),COLORGREEN;
PARTLINE(CLOSE>EMA(LOW,30),EMA(LOW,30)),COLORRED;
PARTLINE(CLOSE<EMA(LOW,30),EMA(LOW,30)),COLORGREEN;
PARTLINE(CLOSE>EMA(HIGH,150),EMA(HIGH,150)),COLORMAGENTA;
PARTLINE(CLOSE<EMA(HIGH,150),EMA(HIGH,150)),COLORBLUE;
PARTLINE(CLOSE>EMA(LOW,150),EMA(LOW,150)),COLORMAGENTA;
PARTLINE(CLOSE<EMA(LOW,150),EMA(LOW,150)),COLORBLUE;
DRAWTEXT(SS,LOW*0.965,'B'),COLORRED;
DRAWICON(SS,LOW*0.98,8);
DRAWTEXT(XX,HIGH*1.035,'S'),COLORGREEN;
DRAWICON(XX,HIGH*1.02,9);

相关信息