快慢多空线 指标 源码[博易大师公式]


Q:=(3*CLOSE+HIGH+LOW+OPEN)/6;
AA10:=EMA(Q,13);
BB10:=ATAN((AA10-REF(AA10,1)))*180/3.1416;
STICKLINE(BB10>1 AND AA10>REF(AA10,1), AA10,REF(AA10,1),8,0),COLORRED;
STICKLINE(BB10<1 AND AA10<REF(AA10,1), AA10,REF(AA10,1),8,1),COLORGREEN;
DRAWNUMBER(ISLASTBAR,AA10,AA10,2),COLOR0000FF,ALIGN0;
AA20:=EMA(Q,34);
BB20:=ATAN((AA20-REF(AA20,1)))*180/3.1416;
STICKLINE(BB20>1,AA20,REF(AA20,1),8,0),COLORYELLOW;
STICKLINE(BB20<1,AA20,REF(AA20,1),8,1),COLORBBCCCC;
DRAWNUMBER(ISLASTBAR,AA20,AA20,2),COLOR00FFFF,ALIGN0;
DRAWTEXT(CROSS(AA10,AA20),AA20*0.99871,'多'),COLOR0000FF;
DRAWTEXT(CROSS(AA20,AA10),AA20*1.00239,'空'),COLOR00FF00;

相关信息