CDP盘中买卖参考指标源码和运用原则


CDP指标1
PT  := REF(HIGH,1)-REF(LOW,1);
CDP : (HIGH + LOW + CLOSE)/3;
AH  : CDP + PT;
AL  : CDP - PT;
NH  : 2*CDP-LOW;
NL  : 2*CDP-HIGH;
CDP指标2
PT:=REF(HIGH,1)-REF(LOW,1);
CDP:=(HIGH+LOW+CLOSE)/3;
最高:=CDP+PT;
最低:=CDP-PT;
近高值:=2*CDP-LOW;
近低值:=2*CDP-HIGH;
CDP盘中买卖价格参考3
PT:=REF(H,1)-REF(L,1);
CDP:(REF(H,1)+REF(L,1)+REF(C,1)*2)/4;
AH:=(CDP+PT);AL:=(CDP-PT);NH:=(2*CDP-L);NL:=(2*CDP-H);
近高值:IF(AH>NH,NH,AH)LINETHICK;
近低值:IF(AL<NL,NL,AL)LINETHICK;
最高:IF(AH>NH,AH,NH)LINETHICK;
最低:IF(AL<NL,AL,NL)LINETHICK;
EXPLAINEX(BETWEEN(O,近高值,近低值),'盘局买入价参考:',近低值,2,0);
EXPLAINEX(BETWEEN(O,近高值,近低值),'盘局卖出价参考:',近高值,2,0);
EXPLAINEX(BETWEEN(O,最高,近高值)OR(O>最高),'盘局买入价参考:',最高,2,0);
EXPLAINEX(BETWEEN(O,最低,近低值)OR(O<最低),'盘局卖出价参考:',最低,2,0);

CDP操盘手+自适应+cdp三合一指标4

VAR1:=(100 - ((90 * (HHV(HIGH,14) - CLOSE)) / (HHV(HIGH,14) - LLV(LOW,14))));
VAR2:=(100 - ((90 * (HHV(HIGH,14) - CLOSE)) / (HHV(HIGH,14) - LLV(LOW,14))));
VAR3:=(100 - MA(((100 * (HHV(HIGH,6) - CLOSE)) / (HHV(HIGH,6) - LLV(LOW,6))),34));
DIR1:=ABS(CLOSE-REF(CLOSE,5));
VIR1:=SUM(ABS(CLOSE-REF(CLOSE,1)),5);
ER1:=DIR1/VIR1;
CS1:=ER1*(0.8-2/8)+2/8;
CQ1:=CS1*CS1;
AMA1:EMA(DMA(CLOSE,CQ1),2) ,COLORWHITE;
DIR2:=ABS(CLOSE-REF(CLOSE,10));
VIR2:=SUM(ABS(CLOSE-REF(CLOSE,1)),10);
ER2:=DIR2/VIR2;
CS2:=ER2*(0.8-2/24)+2/24;
CQ2:=CS2*CS2;
AMA2:EMA(DMA(CLOSE,CQ2),2),COLORGREEN,LINETHICK2;
AMA3:IF(AMA2/REF(AMA2,1)>0.997,AMA2,DRAWNULL),COLORYELLOW,LINETHICK2;
AMA4:IF(AMA2/REF(AMA2,1)>1.001,AMA2,DRAWNULL),COLORRED,LINETHICK2;
STICKLINE((VAR2 < MA(VAR3,6)),CLOSE,OPEN,3,1),COLOR008000;
STICKLINE((VAR2 > MA(VAR3,6)),OPEN,CLOSE,3,1),COLORRED;
STICKLINE(((OPEN > CLOSE) AND (VAR2 > MA(VAR3,6))),(OPEN * 0.998),(CLOSE * 1.0001),2.3,0),COLOR008000;
STICKLINE(((OPEN < CLOSE) AND (VAR2 < MA(VAR3,6))),(CLOSE * 0.998),(OPEN * 1.002),2.3,0),COLORRED;
STICKLINE(((OPEN > CLOSE) AND (VAR2 < MA(VAR3,6))),CLOSE,OPEN,2.3,0),COLOR008000;
DRAWICON(CROSS(VAR2,MA(VAR3,6)),(LOW - (LOW*0.04)),7);
DRAWICON(CROSS(MA(VAR3,6),VAR1),(HIGH+(HIGH*0.03)),8);
PT:=REF(H,1)-REF(L,1);
CDP:=(REF(H,1)+REF(L,1)+REF(C,1)*2)/4;
AH:=CDP+PT;
AL:=CDP-PT;
NH:=CDP*2-REF(L,1);
NL:=CDP*2-REF(H,1);
强:IF(AH>REF(C,1)*1.1,REF(C,1)*1.1,AH),NODRAW;
阻:IF(NH>强,(强-CDP)*0.618+CDP,NH),NODRAW,COLORCYAN;
M:=IF(AL<REF(C,1)/1.1,REF(C,1)/1.1,AL);
撑:IF(NL<M,CDP-(CDP-M)*0.618,NL),NODRAW;
底:IF(AL<REF(C,1)/1.1,REF(C,1)/1.1,AL),NODRAW;


 
CDP短线系统----大智慧L2版5
CDP交易法可以客观指导实战操作时的买卖点。
若将周线的CDP提示点显示在日线上,无疑是个不错的思路。
源码如下:供你参考。
=============================
首先将大智慧2自带的CDP指标打开,修改成以下源码,并且保存
方可实现今日预测明日的功能,原来的公式有误!
th:=max(ref(c,1),h);
tl:=min(ref(c,1),l);
mc:=ref(close,1);
TT:=ref((th-tl),1);
  CDP:(ref(th,1)+ref(tl,1)+2*mc)/4;
  hh:CDP+TT,coloryellow;
  ch:2*CDP-ref(tl,1),color00ff00;
  cd:2*CDP-ref(th,1),color00ff00;
  ll:CDP-TT,coloryellow;
==============================================
在将周CDP源码引入即可实现所需功能
DRAWTEXTABS(20,20,'低吸高抛有把握'),coloryellow;
DRAWTEXTABS(20,40,'粉色K线量饱和'),colorff00ff;
DRAWTEXTABS(20,60,'饱和成头需警惕'),color00ff00;
a:=ema("cdp.cdp#week",1);
周CDP:a,colorwhite;
a1:="cdp.hh#week";
a2:="cdp.ll#week";
a3:="cdp.ch#week";
a4:="cdp.cd#week";
周高:a1,coloryellow;
周低:a2,coloryellow;
次高:a3,color00ff00;
次低:a4,color00ff00;
振幅:(a3/a4-1)*100,colorwhite,linethick0;
drawtext(振幅>20 and l<a2 and c>a2,a2,'▲'),color00ff00;
drawtext(振幅>20 and l<a4 and l>a2 and c>a4,a4,'B'),coloryellow;
drawtext(振幅>10 and h>a1,a1,'★'),color00ff00;
drawtext(振幅>10 and h>a3,a3,'S'),coloryellow;
【量h】:=IF((AMOUNT/C)/(HHV(AMOUNT,21)/HHV(C,21))*100>100,100,(AMOUNT/C)/(HHV(AMOUNT,21)/HHV(C,21))*100);
stickline(【量h】=100,l,h,1,0),colorff00ff;
stickline(【量h】=100 and c>=o,c,o,8,1),colorff00ff;
stickline(【量h】=100 and c<o,c,o,8,0),colorff00ff;
drawtext(【量h】=100 and h>a1,h,'抛'),color00ff00;
drawtext(【量h】=100 and h>a3 and h<a1,h,'抛'),coloryellow;
ZDF:=(C-REF(C,1))/REF(C,1)*100;
STICKLINE(ZDF>9.8,O,C,5,0),COLORRED;
STICKLINE(ZDF<-9.8,O,C,5,0),COLORBLUE;
=====================================================================================
说明:粉色K线表明量能达到饱和程度,量饱和成头!提示风险。
附图如下:
CDP

股票CDP:逆势操作系统(CDP)
市场上推崇追涨杀跌,而不愿参加盘整。实际上,适量参与盘整能够在市场中找到感觉,尤其是在远离成交密集区的低指数。所以在盘局阶段寻求胜算较大的实战技巧是当务之急。
在成交量极低的时候,耐心等待是上策;在成交量温和变化时,不妨根据CDP
设计阻力价和支撑位,通过高抛低吸来降低成本。CDP,即“逆势操作系统”,它是一种根据动量领域变化所定的股价界限,它的计算公式为:
CDP=(H+L+2C)/4
H:前一日最高价;L:前一日最低价;C:前一日收市价
AH(最高价)=CDP+(H—L)
NH(近高价)=CDP?—L
AL(最低价)=CDP—(H—L)
NH(近低价)=CDP?—H
CDP的意义在于预估次日的点位,是一种假想敌的作战方式,判断的关键是看股指(股价)的CDP五个数值(AH、NH、CDP、NL、AL)。这样,投资者参照CDP就可以避免在盘局中最高值的价位追买,而在最低值的价位去追卖。
 
“96.3.6—96.4.24”根据CDP的连续测算,“陆家嘴”一直在14.3—17.8元高低落差为3.5元“箱子”中横盘,次日的最高值、次高价、最低价、次低值历历在目,使在盘局中的操作不为外界干扰而得心应手。
同时,个股的CDP一旦出现较大的偏离,极有可能该股是强势股。
“96.6.4”收市后,“陆家嘴”的CDP显示次日最值为20.52元,次高价为20
.12元,CDP为19.56元,次低价为18.16元。实际上,第二天的最高值为23元,最低价为20元,出现了不应有的偏离,这并不是说CDP不准,而恰恰说明该股已出现领先大盘脱离盘局。显然,在股市中运用该技术指标,有利于发掘潜力股,为大行情作准备。
盘局中,市场重心是上移了呢,还是……?如CDP的AH依次抬高,NH也伴随抬高,则行情已在悄悄往上走;如果CDP的NH不断创出新低,大盘有可能面临向下破位。
市场的稳定呼声越来越高,盘局的时间相对延长,故掌握该指标的运用能够领先一步,洞察大盘先机。
CDP指标的运用原则

找出这五个数值之后,即用前一天的行情波动来将今日的未来行情做一个高低等级的划分,分析者可利用这个高低区分来判断当日的走势。研判的关键是开市价在CDP五个数值的哪个位置,因开市价通常由市场买卖双方心理期望合理价的折衷后形成的,影响当天的走势。

(1)在波动并不很大的情况下,即开市价处在近高值与近低值之间,通常交易者可以在近低值的价们买进,而在近高期的价位卖出;或在近高值的价位卖出,近低值的价位买进。

(2)在波动较大的情况下,即开市价开在最高值或最低值附近时,意味着跳空开高或跳空开低,是一个大行情的发动开始,因此交易者可在最高值的价位去追买,最低值的价位去追卖。通常一个跳空,意味着一个强烈的涨跌,应有相当的利润。

CDP指标的功能分析

(1)CDP最适合于上下振荡的盘局行情,选择高卖低买的区间赚取短线利润。

(2)对于大涨大跌的行情,尤其是冲破阻力价和支撑位时,为避免轧空或横压,需设停损点,防止突发性利多或利空的影响。

CDP指标对广大的投资者来说是一个比较陌生的老指标。它没有引起投资者的注意主要是在现在市场上的技术分析软件中,没有在静态和动态技术栏中设定,而是在各股的分时走势或K线图状态中的分笔或成交明细中隐藏,只有在各股中处于上述状态下,连续按"+"或"-"键才能显现。同时,市场上的技术丛书中也无介绍,从而造成无人问津的境界。

实际上CDP技术指标在一个牛皮盘局中是一个较好的高抛低吸的短线操作工具。该指标与其他技术指标不同之处是没有曲线图表,只有AH、NH、CDP、NL、AL五个数据,其运用法则为:NL和NH是进行短线进出的最佳点位,即:投资者想当日卖出时,把价格定在该股票
CDP指标中的NH值上。若投资者想低价买入该股票,一般把买入价设在NL值上均会成功。而对波段操作者而言AH值和AL值是引导进出场的条件。凡是当然股价向上突破AH值时,股价次日还涨,而股价跌破AL值时,则股价次日将续跌。

从沪深两市实践中证明每当一个连续下跌中的股票,若某日该股突破AH值时,有80%的概率是反转信号,若一个连续上涨的股票,某日股价下跌破AL,则升势宣告结束,因此,该组数据所提供的反转信号要比其它技术指标超前一些。而CDP值只说明股价现阶段的强弱情况,当股价高于该股CDP值时,现阶段市场偏强。反之,偏弱。该技术指标不仅运用简单,并且买卖点位明确,准确率也非常高。