大智慧金城五能指标公式


  AA2:=VOL/((HIGH-LOW)*2-ABS(CLOSE-OPEN));

  买量2:=IF(CLOSE》OPEN,AA2*(HIGH-LOW),IF(CLOSE《OPEN,AA2*((HIGH-OPEN)+(CLOSE-LOW)),VOL/2));

  卖量2:=IF(CLOSE》OPEN,0-AA2*((HIGH-CLOSE)+(OPEN-LOW)),IF(CLOSE《OPEN,0-AA2*(HIGH-LOW),0-VOL/2));

  DDX2:=(买量2+卖量2)/(买量2-卖量2);

  d12:=ema(abs(DDX2),60); {ddx绝对值60日指数平滑移动平均}

  d22:=max(DDX2/d12+7.5,7.5);

  d32:=min(DDX2/d12,10); {能量级别:当日ddx与60日平均值的比值,最高10.0}

  K1:=IF(CLOSE》=REF(CLOSE,1),HIGH-OPEN+CLOSE-LOW+CLOSE-REF(CLOSE,1),HIGH-OPEN+CLOSE-LOW);

  K2:=IF(CLOSE《=REF(CLOSE,1),OPEN-LOW+HIGH-CLOSE+REF(CLOSE,1)-CLOSE,OPEN-LOW+HIGH-CLOSE);

  DT:=VOL*K1/(K1+K2);

  KT:=VOL-DT;

  买量:=SUM(DT,1);

  卖量:=SUM(KT,1);

  DDX3:=EMA(买量-卖量,5)*VOL/sum(vol,60)*0.001;

  d11:=ema(abs(DDX3),60); {ddx绝对值60日指数平滑移动平均}

  d21:=max(DDX3/d11+7.5,7.5);

  d31:=min(DDX3/d11,10); {能量级别:当日ddx与60日平均值的比值,最高10.0}

  TT:=(OPEN+HIGH+LOW+CLOSE)/4;

  AA:=IF(BETWEEN(C,TT,H) OR C=O,VOL,0);

  BB:=IF(BETWEEN(C,TT,L),VOL,0);

  CC:=IF(AA AND BB,0,VOL/3);DDXJ:=10*(AA-(BB+CC))/IF(CAPITAL《1,SUM(VOL,13),CAPITAL);

  jj:=(HIGH+LOW+CLOSE)/3;qj0:=vol/IF(HIGH=LOW,4,HIGH-LOW);

  qj1:=IF(CAPITAL=0,qj0*(jj-MIN(CLOSE,OPEN)),qj0*IF(HIGH=LOW,1,(MIN(OPEN,CLOSE)-LOW)));

  qj2:=IF(CAPITAL=0,qj0*(MIN(OPEN,CLOSE)-LOW),qj0*IF(HIGH=LOW,1,(jj-MIN(CLOSE,OPEN))));

  qj3:=IF(CAPITAL=0,qj0*(HIGH-MAX(OPEN,CLOSE)),qj0*IF(HIGH=LOW,1,(HIGH-MAX(OPEN,CLOSE))));

  qj4:=IF(CAPITAL=0,qj0*(MAX(CLOSE,OPEN)-jj),qj0*IF(HIGH=LOW,1,(MAX(CLOSE,OPEN)-jj)));

  DDXQJ:=((qj1+qj2)-(qj3+qj4))/sum(vol,60);

  dJ11:=ema(abs(DDXQJ),60); {ddx绝对值60日指数平滑移动平均}

  dJ21:=max(DDXQJ/dJ11+7.5,7.5);

  dJ31:=min(DDXQJ/dJ11,10); {能量级别:当日ddx与60日平均值的比值,最高10.0}

  dJ1:=ema(abs(DDXJ),60); {ddx绝对值60日指数平滑移动平均}

  dJ2:=max(DDXJ/dJ1+7.5,7.5);

  dJ3:=min(DDXJ/dJ1,10); {能量级别:当日ddx与60日平均值的比值,最高10.0}

  d1:=ema(abs(“ddx.ddx”),60); {ddx绝对值60日指数平滑移动平均}

  d2:=max(“ddx.ddx”/d1+7.5,7.5);

  d3:=min(“ddx.ddx”/d1,10); {能量级别:当日ddx与60日平均值的比值,最高10.0}

  能量启爆点1:IF(cross(d3,1.5) ,50 ,0),COLORRED,POINTDOT,LINETHICK0;

  STICKLINE(能量启爆点1,0,30,4,0),COLORRED;

  能量启爆点2:IF(cross(dJ3,1.5),50,0),COLORBROWN,POINTDOT,LINETHICK0;

  STICKLINE(能量启爆点2,0,30,4,0),COLORBROWN;

  能量启爆点3:IF(cross(dJ31,1.5),50,0),COLORYELLOW,POINTDOT,LINETHICK0;

  STICKLINE(能量启爆点3,0,30,4,0),COLORYELLOW;

  能量启爆点4:IF(cross(d31,9),50,0),COLORGREEN,POINTDOT,LINETHICK0;

  STICKLINE(能量启爆点4,0,30,4,0),COLORGREEN;

  能量启爆点5:IF(cross(d32,1.5),50,0),COLORBLUE,POINTDOT,LINETHICK0;

  STICKLINE(能量启爆点5,0,30,4,0),COLORBLUE;

相关信息