大智慧明细主图指标公式


  MA1:MA(CLOSE,5);

  MA2:MA(CLOSE,10);

  MA3:MA(CLOSE,20);

  MA4:MA(CLOSE,30);

  MA5:MA(CLOSE,60);

  MA6:MA(CLOSE,120);

  DRAWTEXTABS(10,10,STKLABEL+‘ ’+STKNAME+‘ ’+BKNAME),COLOR00FFFF;

  {涨跌停显示}

  中阳:=(C-REF(C,1))*100/REF(C,1)》=4;

  STICKLINE(中阳=1,H,L,0,0),COLOR123EEE,LINETHICK2;

  STICKLINE(中阳=1,O,C,6,0),COLOR123EEE,LINETHICK2;

  大阳:=(C-REF(C,1))*100/REF(C,1)》=7;

  STICKLINE(大阳=1,H,L,0,0),COLORFF00FF,LINETHICK2;

  STICKLINE(大阳=1,O,C,6,0),COLORFF00FF,LINETHICK2;

  大阴:=(C-REF(C,1))*100/REF(C,1)》=5 AND C《O;

  STICKLINE(大阴=1,H,L,0,0),COLOR00FF00,LINETHICK2;

  STICKLINE(大阴=1,O,C,6,0),COLOR00FF00,LINETHICK2;

  普涨停:=IF((C-REF(C,1))*100/REF(C,1)》=(10-0.01*100/REF(C,1)),1,0);

  ST涨停:=c》1.046*ref(c,1) and c《1.055*ref(c,1) and STRFIND(stkname,‘ST’,1)》0;

  涨停:=普涨停 OR ST涨停;

  STICKLINE(涨停=1,H,L,0,0),COLORYELLOW,LINETHICK2;

  STICKLINE(涨停=1,O,C,6,0),COLORYELLOW,LINETHICK2;

  {www.gupang.com 股旁网_大智慧股票指标公式}

  N:=20;

  总股本(亿):FINANCE2(35)/10000,COLORYELLOW,LINETHICK0;

  流通(亿):FINANCE2(37)/10000,COLORFFFFFF,LINETHICK0;

  均价:=(3*C+H+L+O)/6;

  VAR1:=(8*均价+7*REF(均价,1)+6*REF(均价,2)+5*REF(均价,3)+4*REF(均价,4)+3*REF(均价,5)+2*REF(均价,6)+REF(均价,8))/36;

  VAR2:=(LLV(VAR1,2)+LLV(VAR1,4)+LLV(VAR1,6))/3;

  SZ1:=REF(VAR1,1)=REF(VAR2,1) AND VAR1》VAR2 AND CLOSE》VAR1;

  SZ2:=VAR1》VAR2 AND VAR1》REF(VAR1,1) AND VAR2》REF(VAR2,1) AND H/VAR1《1.1 AND L》VAR2 AND CLOSE》VAR1;

  SZ3:=VAR1》VAR2 AND VAR1》REF(VAR1,1) AND VAR2》=REF(VAR2,1) AND H/VAR1》1.1;

  SZ4:=VAR1》VAR2 AND VAR1》REF(VAR1,1) AND VAR2》REF(VAR2,1) AND CLOSE》VAR2 AND CLOSE《VAR1;

  SZ5:=(VAR1》VAR2 AND VAR2》REF(VAR2,1) AND VAR1《》REF(VAR1,1) AND CLOSE《VAR2) OR (VAR1》VAR2 AND VAR1《REF(VAR1,1) AND VAR2《REF(VAR2,1) AND CLOSE《VAR2);;

  SZ6:=REF(VAR1,1)》REF(VAR2,1) AND VAR1=VAR2 AND CLOSE《VAR2;

  XD1:=VAR1=VAR2 AND CLOSE《VAR2 OR (VAR1《REF(VAR1,1) AND VAR2《REF(VAR2,1) AND REF(VAR1,1)=REF(VAR2,1) AND CLOSE《VAR2);

  XD2:=VAR1=VAR2 AND CLOSE》VAR1;

  SAT:=(AMOUNT/C)/(HHV(AMOUNT,N)/HHV(C,N));

相关信息