大智慧真见招主图指标公式


  A6b:=REF(HIGH,3)=HHV(HIGH,2*3+1);

  B6b:=FILTER(A6b,3);

  C6b:=BACKSET(B6b,3+1);

  D6b:=FILTER(C6b,3);

  A7b:=REF(LOW,3)=LLV(LOW,2*3+1);

  B7b:=FILTER(A7b,3);

  C7b:=BACKSET(B7b,3+1);

  D7b:=FILTER(C7b,3);

  E6b:=(REF(LLV(LOW,2*3),1)+REF(HHV(HIGH,2*3),1))/2;

  E7b:=(HIGH+LOW)/2;

  H6b:=(D6b AND NOT(D7b AND E6b》=E7b)) OR BARSTATUS=2 OR BARSCOUNT(CLOSE)=1;

  H7b:=D6b AND NOT(D7b AND E6b》=E7b);

  L6b:=D7b AND NOT(D6b AND E6b=E7b);

  X6b:=REF(BARSLAST(H6b),1)+1;

  F6b:=BACKSET(H6b AND COUNT(L6b,X6b)》0,LLVBARS(IF(L6b,LOW,10000),X6b));

  G6b:=F6b》REF(F6b,1);

  I6b:=BACKSET(G6b,2);

  LD2b:=I6b》REF(I6b,1);

  L7b:=LD2b OR BARSTATUS=2 OR BARSCOUNT(CLOSE)=1;

  X7b:=REF(BARSLAST(L7b),1)+1;

  F7b:=BACKSET(L7b AND COUNT(H7b,X7b)》0,HHVBARS(IF(H7b,HIGH,0),X7b));

  G7b:=F7b》REF(F7b,1);

  I7b:=BACKSET(G7b,2);

  HD2b:=I7b》REF(I7b,1);

  UU3b:=BACKSET(BARSTATUS=2,BARSLAST(LD2b)+1);

  VV3b:=UU3b》REF(UU3b,1);

  WW3b:=BACKSET(VV3b,REF(BARSLAST(LD2b),1)+2);

  XX3b:=WW3b》REF(WW3b,1);

  DRAWLINE(XX3b,L,VV3b,L,1),Color00FF00;

  UU4b:=BACKSET(BARSTATUS=2,BARSLAST(HD2b)+1);

  VV4b:=UU4b》REF(UU4b,1);

  WW4b:=BACKSET(VV4b,REF(BARSLAST(HD2b),1)+2);

  XX4b:=WW4b》REF(WW4b,1);

  DRAWLINE(XX4b,H,VV4b,H,1),COLOR0000FF;

  MA20:=MA(CLOSE,20);

  MA25:=MA(CLOSE,35);

  DIFF:=EMA(CLOSE,12) - EMA(CLOSE,26);

  DEA :=EMA(DIFF,9);

  MACD := 2*(DIFF-DEA);

  真见招:MA(CLOSE,9),COLOR006600;

  AA12:=MA(CLOSE,12);

  BB10:=((ATAN((真见招 - REF(真见招,1))) * 3.1416) * 10);

  BB12:=((ATAN((AA12 - REF(AA12,1))) * 3.1416) * 10);

  VAR1Q:=((((OPEN + LOW) + HIGH) + CLOSE) / 4);

  强力支撑:=LLV(LOW,30);

  强力压力:=HHV(HIGH,27);

  短底:=EMA(VAR1Q,5);

  支撑:=HHV(短底,60);

  压力一:=HHV(LOW,23);

  压力:=SMA(LOW,5,1);

  中线:MA(CLOSE,3),Color2F2F6F;

  DRAWTEXT(FILTER((((HIGH 》 支撑) AND (CLOSE 《 支撑)) AND ((CLOSE / OPEN) 》 (0 - 1.06))),5),(HIGH)*(1.02),‘逃’),ALIGN1,COLOR009900;

  中轨:=(MA(HIGH,15) * 1.05);

  天:=(MA(LOW,15) * 0.985);

  人:=(MA(LOW,15) * 0.96);

  地:=(((HIGH + LOW) + CLOSE) / 3);

  B1:=HHV(地,(4 * 15));

  B6:=LLV(地,(4 * 15));

  B7:=(B1 - B6);

  B8:=(MA(((地 - B6) / B7),2) * 80);

  VAR1:=(((CLOSE - LLV(LOW,100)) / (HHV(HIGH,100) - LLV(LOW,100))) * 200);

  顶底线:=SMA(VAR1,3,1);

  VAR2:=SMA(顶底线,3,1);

  VAR3:=((3 * 顶底线) - (2 * VAR2));

  VAR4:=LLV(LOW,5);

  VAR5:=HHV(HIGH,5);

  VAR6:=(EMA((((CLOSE - VAR4) / (VAR5 - VAR4)) * 100),4) * 2);

  VAR7:=EMA(((0.667 * REF(VAR6,1)) + (0.333 * VAR6)),2);

  VAR8:=((3 * VAR6) - (2 * VAR7));

  VAR9:=(POW(MA(CLOSE,5),2) + MA(CLOSE,5));

  VARA:=(POW(MA(LOW,5),2) + MA(LOW,5));

  VARB:=(POW(MA(HIGH,5),2) + MA(HIGH,5));

  VARC:=(((((VAR9 - LLV(VARA,64)) / (HHV(VARB,64) - LLV(VARA,64))) * 150) + 65) - 10);

  VARD:=((SMA(VARC,3,1) * 1.5) - 100);

  VARE:=SMA(VARD,3,1);

  VARF:=((3 * VARD) - (2 * VARE));

  VAR10:=(((HIGH + LOW) + (CLOSE * 2)) / 4);

  VAR11:=EMA(VAR10,13);

  VAR12:=STD(VAR10,13);

  VAR13:=(((VAR10 - VAR11) * 100) / VAR12);

  VAR14:=EMA(VAR13,5);

  VAR15:=EMA(VAR14,13);

  VAR16:=((EMA(VAR14,13) + 200) - 100);

  VAR17:=EMA(VAR16,10);

  VAR18:=((3 * VAR16) - (2 * VAR17));

  VAR19:=(((顶底线 + VAR6) + VARD) + VAR16);

  VAR1A:=(((VAR2 + VAR7) + VARE) + VAR17);

  VAR1B:=(((VAR3 + VAR8) + VARF) + VAR18);

  VAR1C:=(((HIGH + LOW) + CLOSE) / 3);

  VAR1D:=((AMOUNT / VOL) / 100);

  VAR1E:=((SUM(AMOUNT,5) / SUM(VOL,5)) / 100);

  VAR1F:=((VAR1C - MA(VAR1C,34)) / (0.015 * AVEDEV(VAR1C,34)));

  VAR20:=DMA(((AMOUNT / VOL) / 100),(VOL / CAPITAL));

  VAR21:=((((HIGH + LOW) + CLOSE) + VAR1C) / 4);

  VAR22:=EMA(VAR21,24);

  VAR23:=STD(VAR21,24);

  VAR24:=(((VAR21 - VAR22) / VAR23) * 100);

  VAR25:=((VAR1C - MA(VAR1C,24)) / (0.015 * AVEDEV(VAR1C,24)));

  VAR26:=EMA(VAR24,5);

  VAR27:=((VAR1D - MA(VAR1D,21)) / (0.015 * AVEDEV(VAR1D,21)));

  VAR28:=((VAR1E - MA(VAR1E,90)) / (0.015 * AVEDEV(VAR1E,90)));

  VAR29:=(((((((VAR28 + VAR27) + VAR26) + VAR25) + VAR1F) / 5) + 165) / 4);

  VAR2A:=(((((VAR19 + VAR1A) + (VAR1B * 30)) / 32) / 5) - 15);

  VAR2B:=(((VAR29 + VAR2A) / 2) / 1.1);

  VAR2C:=VAR2B;

  MID:=MA(CLOSE,26);

  BOLL上:=MID + 2*STD(CLOSE,26);

  BOLL下:=MID -2*STD(CLOSE,26);

  短线:=MA(VAR2C,26);

  MID1:=(短线 + (2 * STD(VAR2C,26)));

  UPPER1:=(短线 - (2 * STD(VAR2C,26)));

  LOWER1:=IF((VAR2C 》 短线),短线,VAR2C);

  短期底:=(LLV(HIGH,30) * 0.9125);

  MA80:=LLV(HIGH,30);

  短期底二:=SMA(CLOSE,2,1);

  趋势:=(MA(LOW,10) * 0.96);

  趋:=(EMA(OPEN,107) * 0.897);

  超跌二:=MA(CLOSE,15);

  MAN:=(SMA(HIGH,21,2) * 1.05);

  上一:=(HHV(短底,60) * 0.92);

  压力二:=(SMA(HIGH,21,2) * 1.035);

  阻挡线:=(SMA(LOW,21,2) * 0.96);

  下档线:=(((CLOSE - LLV(LOW,13)) / (HHV(HIGH,13) - LLV(LOW,13))) * 100);

  RSV:=SMA(下档线,3,1);

  K:=SMA(RSV,3,1);

  D:=((3 * RSV) - (2 * K));

  J:=(((CLOSE - MA(CLOSE,6)) / MA(CLOSE,6)) * 100);

  VAR2P:=(((CLOSE - MA(CLOSE,12)) / MA(CLOSE,12)) * 100);

  VAR3P:=(((CLOSE - MA(CLOSE,24)) / MA(CLOSE,24)) * 100);

  VAR4P:=(((J + (2 * VAR2P)) + (3 * VAR3P)) / 6);

  VAR5P:=MA(VAR4P,3);

  VAR6P:=(((CLOSE - LLV(LOW,34)) / (HHV(HIGH,34) - LLV(LOW,34))) * 100);

  RSV12:=SMA(VAR6P,3,1);

  K12:=SMA(RSV12,3,1);

  D12:=((3 * RSV12) - (2 * K12));

  J12:=(((CLOSE - LLV(LOW,55)) / (HHV(HIGH,55) - LLV(LOW,55))) * 100);

  RSV24:=SMA(J12,3,1);

  K24:=SMA(RSV24,3,1);

  D24:=((3 * RSV24) - (2 * K24));

  VZR2:=LLV(LOW,27);

  VZR3:=HHV(HIGH,34);

  VZR4:=EMA((CLOSE-VZR2)/(VZR3-VZR2)*4,4)*25;

  注意买:=IF((VZR4《10),80,100);

  ZSV:=(C-LLV(L,9))/(HHV(H,9)-LLV(L,9))*100;

  KA:=SMA(ZSV,3,1);

  DB:=SMA(KA,3,1);

  JD:=3*KA-2*DB;

  超跌:=IF(JD《0,10,0);

  BDDD:=LLV(JD,2)=LLV(JD,8);

  买入:=IF(CROSS(JD,REF(JD+0.01,1)) AND BDDD AND JD《20,30,0);

  百比:=(CLOSE/OPEN)《1.0124;

  DRAWTEXT(买入 AND 注意买=100 AND 超跌=0 AND 百比,LOW,‘短炒’),ALIGN1,Color2F2F5F;

  压力位:=IF(CROSS(D24,D),HIGH,L);

  支撑位:=IF((CLOSE 》= MA(CLOSE,20)),80,50);

  U2L:=IF((CLOSE 》= MA(CLOSE,20)),50,20);

  中期支撑:=LLV(HIGH,30);

  RL5:=(SMA(HIGH,5,2) * 1.05);

  上:=(SMA(LOW,5,2) * 0.96);

  下:=SMA(LOW,2,1);

  中:=(((((3 * CLOSE) + HIGH) + LOW) + OPEN) / 6);

  X1:=EMA(中,10);

  X2:=REF(X1,1);

  X3:=((REF(HIGH,1) + REF(LOW,1)) / 2);

  X4:=(MA(CLOSE,21) + (2 * STD(CLOSE,21)));

  X5:=REF(CLOSE,1);

  X6:=((SMA(MAX((CLOSE - X5),0),7,1) / SMA(ABS((CLOSE - X5)),7,1)) * 100);

  X7:=CROSS(79,X6);

  X9:=MA(CLOSE,115);

  X10:=CROSS(X6,79);

  X11:=FILTER(X10,4);

  MA2:=MA(VOL,10);

  DRAWTEXT(X11 and VOL》MA2,(HIGH * 1.04),‘调’),ALIGN1,COLORFF9C00;

  CSy:=(CLOSE-LLV(LOW,8))/(HHV(HIGH,8)-LLV(LOW,8))*100;

  YJD:=(EMA(CSy,3)-50)*2;

  见风2:=REF(YJD》70,1);

  过滤:=FILTER(见风2,2);

  趋势线:=3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1);

  趋势参考:=EMA(趋势线,3);

  高顶:VERTLINE(趋势线》85 AND 趋势线《105 AND (趋势线/趋势参考)》1.03,3),COLOR003300;

  趋势参考2:=趋势线》20 and REF(趋势线《80,1);

  DRAWTEXT(过滤 and 趋势参考2 and VOL》MA2,(HIGH * 1.06),‘减’),ALIGN1,COLOR00FF00;

  老婆:=(真见招-中线)》0.038;

  老公:=(真见招-REF(真见招,1))《 0.0125 AND 中线《REF(中线,1) AND 中线》真见招;

  反正切:=(C+L+H)/3;

  二奶:=MA(反正切,9)-REF(MA(反正切,3),1)》0.1;

  二奶2:=MA(反正切,9)-REF(MA(反正切,3),1)》0.125;

  深底:VERTLINE(趋势线《=6.1 AND 二奶2 AND VOL》MA2*0.668 AND (趋势参考/趋势线)》1.035,4),Color2F0F3F;

  逃遁:=(SMA(HIGH,21,2) * 1.05);

  STICKLINE((OPEN 》= CLOSE),CLOSE,OPEN,8,0),COLORFF1100;

  STICKLINE((OPEN 》= CLOSE),CLOSE,OPEN,6,0),COLORFF3300;

  STICKLINE((OPEN 》= CLOSE),CLOSE,OPEN,5,0),COLORFF5500;

  STICKLINE((OPEN 》= CLOSE),CLOSE,OPEN,4,0),COLORFF7700;

  STICKLINE((OPEN 》= CLOSE),CLOSE,OPEN,3,0),COLORFF9900;

  STICKLINE((OPEN 》= CLOSE),CLOSE,OPEN,2,0),COLORFFBB00;

  STICKLINE((OPEN 》= CLOSE),CLOSE,OPEN,1,0),COLORFFDD00;

  STICKLINE(CLOSE》=OPEN,CLOSE,OPEN,8,0) ,COLOR000055;

  STICKLINE(CLOSE》=OPEN,CLOSE,OPEN,6,0) ,COLOR000066;

  STICKLINE(CLOSE》=OPEN,CLOSE,OPEN,5,0) ,COLOR000077;

  STICKLINE(CLOSE》=OPEN,CLOSE,OPEN,4,0) ,COLOR000099;

  STICKLINE(CLOSE》=OPEN,CLOSE,OPEN,3,0) ,COLOR0000BB;

  STICKLINE(CLOSE》=OPEN,CLOSE,OPEN,2,0) ,COLOR0000DD;

  STICKLINE(CLOSE》=OPEN,CLOSE,OPEN,1,0) ,COLOR0000FF;

  STICKLINE(((((CLOSE / OPEN) 》 1.04) AND (CLOSE 《 逃遁)) AND 趋势线《25 AND ((CLOSE - REF(CLOSE,1)) 》 0)),CLOSE,OPEN,8,0),COLORFF11FF;

  STICKLINE(((((CLOSE / OPEN) 》 1.04) AND (CLOSE 《 逃遁)) AND 趋势线《25 AND ((CLOSE - REF(CLOSE,1)) 》 0)),CLOSE,OPEN,6,0),COLORFF33FF;

  STICKLINE(((((CLOSE / OPEN) 》 1.04) AND (CLOSE 《 逃遁)) AND 趋势线《25 AND ((CLOSE - REF(CLOSE,1)) 》 0)),CLOSE,OPEN,5,0),COLORFF55FF;

  STICKLINE(((((CLOSE / OPEN) 》 1.04) AND (CLOSE 《 逃遁)) AND 趋势线《25 AND ((CLOSE - REF(CLOSE,1)) 》 0)),CLOSE,OPEN,4,0),COLORFF77FF;

  STICKLINE(((((CLOSE / OPEN) 》 1.04) AND (CLOSE 《 逃遁)) AND 趋势线《25 AND ((CLOSE - REF(CLOSE,1)) 》 0)),CLOSE,OPEN,3,0),COLORFF99FF;

  STICKLINE(((((CLOSE / OPEN) 》 1.04) AND (CLOSE 《 逃遁)) AND 趋势线《25 AND ((CLOSE - REF(CLOSE,1)) 》 0)),CLOSE,OPEN,2,0),COLORFFBBFF;

  STICKLINE(((((CLOSE / OPEN) 》 1.04) AND (CLOSE 《 逃遁)) AND 趋势线《25 AND ((CLOSE - REF(CLOSE,1)) 》 0)),CLOSE,OPEN,1,0),COLORFFDDFF;

  STICKLINE(((((CLOSE 《 REF(CLOSE,1)) AND (CLOSE 《 REF(CLOSE,1))) AND 趋势线》75 AND (HIGH 》 逃遁)) AND (CLOSE 《 逃遁)),CLOSE,OPEN,8,0),COLOR003300;

  STICKLINE(((((CLOSE 《 REF(CLOSE,1)) AND (CLOSE 《 REF(CLOSE,1))) AND 趋势线》75 AND (HIGH 》 逃遁)) AND (CLOSE 《 逃遁)),CLOSE,OPEN,6,0),COLOR005500;

  STICKLINE(((((CLOSE 《 REF(CLOSE,1)) AND (CLOSE 《 REF(CLOSE,1))) AND 趋势线》75 AND (HIGH 》 逃遁)) AND (CLOSE 《 逃遁)),CLOSE,OPEN,5,0),COLOR007700;

  STICKLINE(((((CLOSE 《 REF(CLOSE,1)) AND (CLOSE 《 REF(CLOSE,1))) AND 趋势线》75 AND (HIGH 》 逃遁)) AND (CLOSE 《 逃遁)),CLOSE,OPEN,4,0),COLOR009900;

  STICKLINE(((((CLOSE 《 REF(CLOSE,1)) AND (CLOSE 《 REF(CLOSE,1))) AND 趋势线》75 AND (HIGH 》 逃遁)) AND (CLOSE 《 逃遁)),CLOSE,OPEN,3,0),COLOR00BB00;

  STICKLINE(((((CLOSE 《 REF(CLOSE,1)) AND (CLOSE 《 REF(CLOSE,1))) AND 趋势线》75 AND (HIGH 》 逃遁)) AND (CLOSE 《 逃遁)),CLOSE,OPEN,2,0),COLOR00DD00;

  STICKLINE(((((CLOSE 《 REF(CLOSE,1)) AND (CLOSE 《 REF(CLOSE,1))) AND 趋势线》75 AND (HIGH 》 逃遁)) AND (CLOSE 《 逃遁)),CLOSE,OPEN,1,0),COLOR00FF00;

  阻挡:=(SMA(LOW,21,2) * 0.94);

  DRAWTEXT((((((CROSS(VAR2C,短线) AND ((CLOSE - REF(HIGH,1)) 》 0)) AND ((中线 - REF(中线,1)) 》 0)) AND (HIGH 《= 压力一)) AND (CLOSE 《 MA20)) AND (LOW 《= 中线)),(LOW - 0.06),‘关注’),ALIGN1,COLORFAABEC;

  DRAWTEXT(FILTER(((((((LOW 《= 天) AND (CLOSE 》= MA20)) AND (HIGH 《 压力一)) AND ((天 - REF(天,1)) 》 0)) AND (CLOSE 《 压力一)) AND ((MA20 - REF(MA20,1)) 》 0)),6) AND (LOW《=((强力压力+短期底)/2)),(LOW - 0.24),‘全仓’),ALIGN1,Color4F2F4F;

  DRAWTEXT(((((LOW 《= 上) AND (HIGH 》= 短期底)) AND (CLOSE 》= 中期支撑))AND (LOW《=((强力压力+强力支撑)/2)) AND((CLOSE/LOW)》1.026 )) ,L * 0.97,‘短’),ALIGN1,COLOR0000FF;

  DRAWTEXT(((((LOW 《= 上) AND (HIGH 》= 短期底)) AND (CLOSE 》= 中期支撑))AND (LOW《=((强力压力+强力支撑)/2)) AND((CLOSE/LOW)》1.026 )) ,L * 0.92,‘炒’),ALIGN1,COLOR0000FF;

  DRAWTEXT((((CROSS(MA20,压力位) AND (LOW 《= MA20)) AND ((MA20 - REF(MA20,1)) 》 0.02)) AND 老婆 AND (MACD》-0.03)),(LOW - 0.07),‘佳’),ALIGN1,COLOR999999;

  DRAWTEXT((((CROSS(MA20,压力位) AND (LOW 《= MA20)) AND ((MA20 - REF(MA20,1)) 》 0.02)) AND 老公 AND (MACD》-0.03)),(LOW - 0.07),‘佳’),ALIGN1,Color9A589F;

  DRAWTEXT(((CROSS(MA25,压力位) AND (LOW 《= MA25)) AND ((MA25 - REF(MA25,1)) 》 0.02)) AND (LOW《=((强力压力+短期底)/2)),(LOW - 0.35),‘绝佳’),ALIGN1,COLOR0000B7;

  DRAWTEXT((LOW 《= 强力支撑) AND (CLOSE 》 LOW) AND((CLOSE/LOW)》1.0175) AND (LOW/BOLL下)《0.9375,L * 0.935,‘底’),ALIGN1,COLOR0000B7;

  B1u:=SUM(IF(CLOSE》REF(CLOSE,1),VOL,IF(CLOSE 《 REF(CLOSE,1),0-VOL,0)),0);

  B2u:=40;

  B3u:=IF(CLOSE》LLV(CLOSE,B2u),1,-1)*IF(B1u》LLV(B1u,B2u),1,-1);

  B4u:=IF(B3u=-1,1,0);

  B5u:=COUNT(B4u=1,8)》3;

  B6u:=SUM(AMOUNT,13)/(AMOUNT/VOL/100)/100;

  B7u:=DMA((HIGH+LOW+CLOSE)/3,VOL/B6u);

  B8u:=(CLOSE-B7u)/B7u*100《-21;

  B9u:=(CLOSE-MIN(REF(CLOSE,5)*0.830,REF(CLOSE,21)*0.720))/CLOSE《0.045;

  DRAWTEXT(B8u AND B9u AND 趋势线》-1.5 and VOL》MA2*0.7 AND B5u,(LOW - 0.42),‘财’),ALIGN1,Color9DFFFF;

  见招线:=100*(CLOSE-LLV(LOW,10))/(HHV(CLOSE,10)-LLV(LOW,10));

  曾见招:=IF(CROSS(见招线,3),1,0) AND 二奶2;

  招线:VERTLINE(曾见招 ,1),COLOR555555;

  a1n:=(C/MA(C,48))《0.75;

  a2n:=(C/MA(C,70))《0.70;

  a3n:=a1n AND a2n;

  a4n:=V《REF(V,1)*2.8 AND (COUNT(C《O*0.966,2)=2 OR COUNT(H/L》1.1085,5)》2.99);

  a5n:=a3n AND ((C-L)/C》0.03 OR C》REF(C,1)*1.012) AND a4n;

  a7n:=(((CLOSE / MA(CLOSE,40)) * 100) 《 78);

  a8n:=(((CLOSE / MA(CLOSE,60)) * 100) 《 74);

  a9n:=(HIGH 》 (LOW * 1.08));

  a10n:=(a9n AND (COUNT(a9n,5) 》2));

  a11n:=DMA(CLOSE,VOL/SUM(VOL,34));

  a12n:=DMA(CLOSE,VOL/SUM(VOL,13));

  a13n:=(CLOSE-a11n)/a11n*100;

  a14n:=(CLOSE-a12n)/a12n*100;

  a15n:=a14n《=-20 AND a13n《=-35.8;

  AAn:=IF((a10n AND (a7n OR a8n)),2,0);

  BBn:=C/REF(C,25)《=0.698;

  CCn:=(SMA(MAX(C-REF(C,2),0),7,1)/SMA(ABS(C-REF(C,2)),7,1)*100)《15;

  V3n:=(CLOSE-LLV(LOW,8))/(HHV(HIGH,8)-LLV(LOW,8))*100;

  ddn:=SMA(V3n,2,1);

  V5n:=SMA(ddn,2,1);

  een:=IF(ddn》REF(ddn,1) AND REF(ddn,1)《REF(ddn,2) AND ddn《20 ,1.5,0);

  ffn:=BBn AND AAn AND CCn AND een;

  宝宝1:=a5n AND a15n AND ffn;

  Vbd1:=CLOSE/MA(CLOSE,15)*100《77.3;

  Vbd2:=CLOSE/MA(CLOSE,30)*100《69.4;

  Vbd3:=HIGH》=LOW*1.13146;

  Vbd4:=Vbd3 AND COUNT(Vbd3,6)》=2;

  宝宝2:=(Vbd4 AND (Vbd1 OR Vbd2) AND COUNT(HIGH=LOW AND CLOSE=OPEN AND CLOSE《REF(CLOSE,1),3)=0)*10;

  DRAWTEXT(宝宝2,L * 0.905,‘宝’),ALIGN1,LINETHICK3,COLOR0000FF;

  DRAWTEXT(宝宝1,L * 0.903,‘宝’),ALIGN1,LINETHICK3,ColorE6E8FA;

  宝宝3:=c/ma(c,48)《0.74 and c/ma(c,70)《0.69 and ((c-l)/c》0.03 or c》ref(c,1)*0.97) and v《ref(v,1)*2.8 and (count(c《o*0.958,2)=2 or count(h/l》1.1072,5)》3) and (close-dma(close,vol/sum(vol,13)))/dma(close,vol/sum(vol,13))*100《=-25.2 and (close-dma(close,vol/sum(vol,34)))/dma(close,vol/sum(vol,34))*100《=-29.8;

  DRAWTEXT(宝宝3,L * 0.901,‘宝’),ALIGN1,LINETHICK3,COLORFF9C00;

  DRAWTEXTREL(408.5,980.5,STKLABEL+STKNAME+‘ 流通股:’+NUMTOSTRN(FINANCE2(37),0)+‘万’),Color1DFFFF;

  DRAWTEXTABS(2,4,‘市盈率:’+DYNAINFO(39)),Color9DFFFF;

  DRAWTEXTABS(110,4,‘市净率:’+c/FINANCE2(4)),Color9DFFFF;

  DRAWTEXTABS(218,4,‘最新收益:’+FINANCE2(3)+‘元 ’),Color9DFFFF;

  DRAWTEXTABS(326,4,‘莸利比例:’+WINNER(c )*100),Color9DFFFF;

  DRAWTEXTABS(434,4,‘主营收入同比增长:’+FINANCE2(11)+‘% ’),Color9DFFFF;

  DRAWTEXTABS(588,4,‘净利润同比增长:’+FINANCE2(10)+‘% ’),Color9DFFFF;

  DRAWTEXTABS(2,17,‘板块名称:’+BKNAME),Color9DFFFF;

  DRAWTEXTABS(688,17,‘评级:’+Extrastring(‘评级’)),Color9DFFFF;

  {www.gupang.com 股旁网_大智慧股票指标公式}

  TJ:=IF((C-REF(C,1))/REF(C,1)》0.025,1,0);

  yl:=IF(C》REF(O,BARSLAST(TJ =1)),REF(O,BARSLAST(TJ =1)),0);

  FT:=BARSLAST(yl);

  YLX:=REF(yl,FT);

  平台突破:=CROSS(C,YLX);

  VAk2:=REF(LOW,1);

  VAk3:=SMA(ABS(LOW-VAk2),13,1)/SMA(MAX(LOW-VAk2,0),13,1)*100;

  VAk4:=EMA(IF(CLOSE*1.2,VAk3*13,VAk3/13),13);

  VAk5:=LLV(LOW,34);

  VAk6:=HHV(VAk4,34);

  VAk7:=IF(LLV(LOW,56),1,0);

  VAk8:=EMA(IF(LOW《=VAk5,(VAk4+VAk6*2)/2,0),3)/618*VAk7;

  主力进场:=VAk8》REF(VAk8,1);

  进场:=ref(主力进场,1);

  DRAWTEXT(进场 AND 平台突破 ,L * 0.97,‘进’),ALIGN1,COLOR8000FF;

  VAME:=MA(100*(CLOSE-LLV(CLOSE,34))/(HHV(HIGH,34)-LLV(LOW,34)),5)-20;

  VAMF:=100-3*SMA((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1)+2*SMA(SMA((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1),15,1);

  VAM10:=100-3*SMA((OPEN-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1)+2*SMA(SMA((OPEN-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1),15,1);

  VAM11:=VAMF《REF(VAM10,1) AND VOL》REF(VOL,1) AND CLOSE》REF(CLOSE,1);

  DRAWTEXT(VAM11 AND 趋势线《35 AND COUNT(VAM11,30)=1,LOW*0.95,‘动’),ALIGN1,COLORFF00FF;

  VAM12:=(HIGH+LOW+CLOSE)/3;

  VAM13:=(VAM12-MA(VAM12,14))/(0.015*AVEDEV(VAM12,14));

  VAM14:=(VAM12-MA(VAM12,70))/(0.015*AVEDEV(VAM12,70));

  VAM15:=IF(VAM13》=150 AND VAM13《200 AND VAM14》=150 AND VAM14《200,10,0);

  VAM16:=IF(VAM13《=-150 AND VAM13》-200 AND VAM14《=-150 AND VAM14》-200,-10,VAM15);

  VAM17:=(CLOSE-MA(CLOSE,13))/MA(CLOSE,13)*100;

  VAM18:=100-ABS(VAM17);

  VAM19:=IF(VAM18《90,VAM18,100);

  VAM1A:=IF(VAME》0,VAME,0);

  VAM1B:=IF(VAM14》=200 AND VAM13》=150,15,IF(VAM14《=-200 AND VAM13《=-150,-15,VAM16))+60;

  VAM1C:=VAM1A》48 AND VAM1B》60 AND VAM19《100;

  DRAWTEXT(VAM1C AND COUNT(VAM1C,30)=1,HIGH*1.03,‘战’),ALIGN1,COLORFF00FF;

相关信息