大智慧预报顶底指标公式


  {TY:=C;

  HD:=FILTER(BACKSET(FILTER(REF(TY,10)=HHV(TY,2*10+1),10),10+1),10);

  LD:=FILTER(BACKSET(FILTER(REF(TY,10)=LLV(TY,2*10+1),10),10+1),10);

  A:=REF(C,BARSLAST(HD));

  B:=REF(C,BARSLAST(LD));

  T1:=BARSLAST(HD)《BARSLAST(LD) AND NOT(HD) ;

  T2:=BARSLAST(HD)》BARSLAST(LD) AND NOT(LD);

  Var3:=LLV(H,240);}{H为最高价}

  {Var4:=100*(CLOSE-Var3)/Var3;}{CLOSE收盘价}

  {Var5:=(CLOSE-LLV(LOW,528))/(HHV(H,528)-LLV(LOW,528))*100;}{LOW最低价}

  {Var6:=(CLOSE-LLV(CLOSE,530))/(HHV(CLOSE,530)-LLV(CLOSE,530))*100;

  Var7:=0;

  Var8:=MA(HHV(CLOSE-REF(CLOSE,1),0),34)/MA(ABS(CLOSE-REF(CLOSE,1)),7)*100;

  Var9:=MA(HHV(CLOSE-REF(CLOSE,1),0),13)/MA(ABS(CLOSE-REF(CLOSE,1)),13)*100;

  VarA:=BARSCOUNT(CLOSE);

  VarB:=Var8《20 AND Var9《23 AND VarA》35;

  VarC:=VarB AND COUNT(VarB,1)=1;

  VarD:=EMA(CLOSE,21)-EMA(CLOSE,8);

  VarE:=EMA(VarD,5);

  VarF:=TROUGH(3,6,1)《4 AND CROSS(VarD,VarE);

  Var10:=IF(TROUGH(3,16,1)=0 AND H》LOW+0.04,4,0);}

  Var12:=ZIG(3,6)《REF(ZIG(3,6),1) AND REF(ZIG(3,6),1)》=REF(ZIG(3,6),2) AND REF(ZIG(3,6),2)》=REF(ZIG(3,6),3);

  Var14:=ZIG(3,22)《REF(ZIG(3,22),1) AND REF(ZIG(3,22),1)》=REF(ZIG(3,22),2) AND REF(ZIG(3,22),2)》=REF(ZIG(3,22),3);

  Var16:=ZIG(3,51)《REF(ZIG(3,51),1) AND REF(ZIG(3,51),1)》=REF(ZIG(3,51),2) AND REF(ZIG(3,51),2)》=REF(ZIG(3,51),3);

  Var18:=ZIG(3,72)《REF(ZIG(3,72),1) AND REF(ZIG(3,72),1)》=REF(ZIG(3,72),2) AND REF(ZIG(3,72),2)》=REF(ZIG(3,72),3);

  卖点:(Var12+Var14+Var16+Var18),stick,precis0,colorgreen;

  drawtext(卖点,卖点*1,‘卖’),colorgreen;

  Var11:=ZIG(3,6)》REF(ZIG(3,6),1) AND REF(ZIG(3,6),1)《=REF(ZIG(3,6),2) AND REF(ZIG(3,6),2)《=REF(ZIG(3,6),3);

  Var13:=ZIG(3,22)》REF(ZIG(3,22),1) AND REF(ZIG(3,22),1)《=REF(ZIG(3,22),2) AND REF(ZIG(3,22),2)《=REF(ZIG(3,22),3);

  Var15:=ZIG(3,51)》REF(ZIG(3,51),1) AND REF(ZIG(3,51),1)《=REF(ZIG(3,51),2) AND REF(ZIG(3,51),2)《=REF(ZIG(3,51),3);

  Var17:=ZIG(3,72)》REF(ZIG(3,72),1) AND REF(ZIG(3,72),1)《=REF(ZIG(3,72),2) AND REF(ZIG(3,72),2)《=REF(ZIG(3,72),3);

  {Var19:=EMA(CLOSE,2)-EMA(CLOSE,150);

  Var1A:=EMA(Var19,100);

  Var1B:=2*(Var19-Var1A);

  Var1C:=POW(Var1B,3)*0.1+POW(Var1B,1);

  Var1D:=SQRT(SQRT(LOW*H*O*CLOSE));}{O开盘价}

  {Var1E:=EMA(Var1D*0.97,3);

  Var1F:=(H+LOW+CLOSE)/3;

  Var20:=(Var1F-MA(Var1F,14))/(0.015*AVEDEV(Var1F,14));

  Var21:=CROSS(Var1E,LOW);}

  买点:(Var11+Var13+Var15+Var17);

  drawtext(买点,买点*1,‘买’),colorred;

  {Var22:=买点1 AND VarF AND VarC AND Var21 AND Var4《0 AND Var5=0 AND Var6=0 AND Var20《(-110);

  VAR1:=MA(CLOSE,5);

  VAR2:=MA(CLOSE,10);

  VAR31:=MA(CLOSE,30);

  VARB1:=SUM(CLOSE*V*100,28)/SUM(V*100,28);}{V成交量}

  {VARC1:=INTPART(VARB1*100)/100;

  VARD1:=EMA(CLOSE,5)-EMA(CLOSE,10);

  VARE1:=EMA(VARD1,9);

  VAR131:=REF(VARE1,1);

  VAR141:=VARE1;

  VAR151:=VAR141-VAR131;

  VAR161:=REF(VARD1,1);

  VAR171:=VARD1;

  VAR181:=VAR171-VAR161;

  VAR191:=O;

  VAR1A1:=CLOSE;};

  drawtextabs(0,0,‘未来函数 谨慎使用’),coloryellow;

相关信息