大智慧红地毯主图指标公式


  1、准确性更高。2、看得更长远。3、信号更明确,波段更分明。4、周K线还兼容了部分日K线的优点,加入五日资金动态可看清主力动向。

  VAR1:=CLOSE》REF(CLOSE,1) AND CLOSE》REF(CLOSE,2);

  VAR2:=REF(VAR1,1) AND CLOSE《=REF(CLOSE,1) AND CLOSE》=REF(CLOSE,2);

  VAR3:=REF(VAR2,1) AND CLOSE》=REF(CLOSE,1) AND CLOSE《=REF(CLOSE,2);

  VAR4:=REF(VAR3,1) AND CLOSE《=REF(CLOSE,1) AND CLOSE》=REF(CLOSE,2);

  VAR5:=REF(VAR4,1) AND CLOSE》=REF(CLOSE,1) AND CLOSE《=REF(CLOSE,2);

  VAR6:=REF(VAR5,1) AND CLOSE《=REF(CLOSE,1) AND CLOSE》=REF(CLOSE,2);

  VAR7:=REF(VAR6,1) AND CLOSE》=REF(CLOSE,1) AND CLOSE《=REF(CLOSE,2);

  VAR8:=REF(VAR7,1) AND CLOSE《=REF(CLOSE,1) AND CLOSE》=REF(CLOSE,2);

  VAR9:=REF(VAR8,1) AND CLOSE》=REF(CLOSE,1) AND CLOSE《=REF(CLOSE,2);

  VARA:=REF(VAR9,1) AND CLOSE《=REF(CLOSE,1) AND CLOSE》=REF(CLOSE,2);

  VARB:=REF(VARA,1) AND CLOSE》=REF(CLOSE,1) AND CLOSE《=REF(CLOSE,2);

  VARC:=REF(VARB,1) AND CLOSE《=REF(CLOSE,1) AND CLOSE》=REF(CLOSE,2);

  STICKLINE(VAR1 OR VAR2 OR VAR3 OR VAR4 OR VAR5 OR VAR6 OR VAR7 OR VAR8 OR VAR9 OR VARA

  OR VARB OR VARC,CLOSE,REF(CLOSE,1),8,0),COLOR000055;

  STICKLINE(VAR1 OR VAR2 OR VAR3 OR VAR4 OR VAR5 OR VAR6 OR VAR7 OR VAR8 OR VAR9 OR VARA

  OR VARB OR VARC,CLOSE,REF(CLOSE,1),5,0),COLOR000077;

  STICKLINE(VAR1 OR VAR2 OR VAR3 OR VAR4 OR VAR5 OR VAR6 OR VAR7 OR VAR8 OR VAR9 OR VARA

  OR VARB OR VARC,CLOSE,REF(CLOSE,1),3,0),COLOR0000bb;

  STICKLINE(VAR1 OR VAR2 OR VAR3 OR VAR4 OR VAR5 OR VAR6 OR VAR7 OR VAR8 OR VAR9 OR VARA

  OR VARB OR VARC,CLOSE,REF(CLOSE,1),0,0),COLOR0000FF;

  DLX:=(EMA(CLOSE,17)-REF(EMA(CLOSE,17),1));

  DLX1:=SUM(DLX,3);

  DLX2:=MA(DLX1,5);

  VARD:=CLOSE《REF(CLOSE,1) AND CLOSE《REF(CLOSE,2);

  VARE:=REF(VARD,1) AND CLOSE》=REF(CLOSE,1) AND CLOSE《=REF(CLOSE,2);

  VARF:=REF(VARE,1) AND CLOSE《=REF(CLOSE,1) AND CLOSE》=REF(CLOSE,2);

  VAR10:=REF(VARF,1) AND CLOSE》=REF(CLOSE,1) AND CLOSE《=REF(CLOSE,2);

  VAR11:=REF(VAR10,1) AND CLOSE《=REF(CLOSE,1) AND CLOSE》=REF(CLOSE,2);

  VAR12:=REF(VAR11,1) AND CLOSE》=REF(CLOSE,1) AND CLOSE《=REF(CLOSE,2);

  VAR13:=REF(VAR12,1) AND CLOSE《=REF(CLOSE,1) AND CLOSE》=REF(CLOSE,2);

  VAR14:=REF(VAR13,1) AND CLOSE》=REF(CLOSE,1) AND CLOSE《=REF(CLOSE,2);

  VAR15:=REF(VAR14,1) AND CLOSE《=REF(CLOSE,1) AND CLOSE》=REF(CLOSE,2);

  VAR16:=REF(VAR15,1) AND CLOSE》=REF(CLOSE,1) AND CLOSE《=REF(CLOSE,2);

  VAR17:=REF(VAR16,1) AND CLOSE《=REF(CLOSE,1) AND CLOSE》=REF(CLOSE,2);

  VAR18:=REF(VAR17,1) AND CLOSE》=REF(CLOSE,1) AND CLOSE《=REF(CLOSE,2);

  STICKLINE(VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 OR VAR14 OR VAR15 OR VAR16 OR

  VAR17 OR VAR18,CLOSE,REF(CLOSE,1),8,0),COLORff7700;

  STICKLINE(VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 OR VAR14 OR VAR15 OR VAR16 OR

  VAR17 OR VAR18,CLOSE,REF(CLOSE,1),5,0),COLORffbb00;

  STICKLINE(VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 OR VAR14 OR VAR15 OR VAR16 OR

  VAR17 OR VAR18,CLOSE,REF(CLOSE,1),3,0),COLORffdd00;

  STICKLINE(VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 OR VAR14 OR VAR15 OR VAR16 OR

  VAR17 OR VAR18,CLOSE,REF(CLOSE,1),0,0),COLORffFF00;

  VAR19:=REF(VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 OR VAR14 OR VAR15 OR VAR16 OR

  VAR17 OR VAR18,1) AND VAR1;

  VAR1A:=REF(VAR1 OR VAR2 OR VAR3 OR VAR4 OR VAR5 OR VAR6 OR VAR7 OR VAR8 OR VAR9 OR VARA OR VARB OR VARC,1)

  AND VARD;

  STICKLINE(VAR1A,REF(CLOSE,1),REF(CLOSE,2),8,0),COLOR0055AA;

  STICKLINE(VAR1A,REF(CLOSE,1),REF(CLOSE,2),5,0),COLOR0077CC;

  STICKLINE(VAR1A,REF(CLOSE,1),REF(CLOSE,2),3,0),COLOR0099DD;

  STICKLINE(VAR1A,REF(CLOSE,1),REF(CLOSE,2),0,0),COLOR00BBFF; S1:=last(DLX1《DLX2 and DLX1《REF(DLX1,1));

  S2:=last(DLX1》=DLX2 and DLX1》=REF(DLX1,1));

  drawtext(S1》0,H*1.04,STR(S1)),color00FF00,LINETHICK1,align1,valign0;

  drawtext(S2》0,L*1,STR(S2)),color0000FF,LINETHICK1,align1,valign0;

  反压线:HHV(FORCAST(CLOSE,10),18),Linethick1,CoLorEE8FFF;

  年:=MA(CLOSE,26);

  STICKLINE((CLOSE》=年) AND (CLOSE》=OPEN),CLOSE,OPEN,4.5,0),CoLor0000AA;

  STICKLINE((CLOSE》=年) AND (CLOSE》=OPEN),CLOSE,OPEN,3.5,0),CoLor0000CC;

  STICKLINE((CLOSE》=年) AND (CLOSE》=OPEN),CLOSE,OPEN,3,0),CoLor0000EE;

  STICKLINE((CLOSE》=年) AND (CLOSE》=OPEN),CLOSE,OPEN,1,0),CoLor0000FF;

  STICKLINE((CLOSE》=年) AND (CLOSE》=OPEN),HIGH,LOW,0,0),CoLor0000FF;

  STICKLINE((CLOSE》=年) AND (CLOSE《OPEN),CLOSE,OPEN,4.5,0),CoLor0000AA;

  STICKLINE((CLOSE》=年) AND (CLOSE《OPEN),CLOSE,OPEN,3.5,0),CoLor0000CC;

  STICKLINE((CLOSE》=年) AND (CLOSE《OPEN),CLOSE,OPEN,3,0),CoLor0000EE;

  STICKLINE((CLOSE》=年) AND (CLOSE《OPEN),CLOSE,OPEN,1,0),CoLor0000FF;

  STICKLINE((CLOSE》=年) AND (CLOSE《OPEN),OPEN,HIGH,0,0),CoLor0000FF;

  STICKLINE((CLOSE》=年) AND (CLOSE《OPEN),CLOSE,LOW,0,0),CoLor0000FF;

  STICKLINE((CLOSE《年) AND (CLOSE》OPEN),CLOSE,OPEN,4.5,0),CoLorAAAA00;

  STICKLINE((CLOSE《年) AND (CLOSE》OPEN),CLOSE,OPEN,3.5,0),CoLorCCCC00;

  STICKLINE((CLOSE《年) AND (CLOSE》OPEN),CLOSE,OPEN,3,0),CoLorEEEE00;

  STICKLINE((CLOSE《年) AND (CLOSE》OPEN),CLOSE,OPEN,1,0),CoLorFFFF00;

  STICKLINE((CLOSE《年) AND (CLOSE《=OPEN),CLOSE,OPEN,4.5,0),CoLorAAAA00;

  STICKLINE((CLOSE《年) AND (CLOSE《=OPEN),CLOSE,OPEN,3.5,0),CoLorCCCC00;

  STICKLINE((CLOSE《年) AND (CLOSE《=OPEN),CLOSE,OPEN,3,0),CoLorEEEE00;

  STICKLINE((CLOSE《年) AND (CLOSE《=OPEN),CLOSE,OPEN,1,0),CoLorFFFF00;

  STICKLINE((CLOSE《年) AND (CLOSE《=OPEN),HIGH,LOW,0,0),CoLorFFFF00;

  STICKLINE((CLOSE《年) AND (CLOSE》OPEN),CLOSE,HIGH,0,0),CoLorFFFF00;

  STICKLINE((CLOSE《年) AND (CLOSE》OPEN),OPEN,LOW,0,0),CoLorFFFF00;

  VAR1:=((OPEN-REF(CLOSE,1))/(REF(CLOSE,1)))*(100);

  VAR2:=(VAR1》3);

  VAR3:=(VAR1《(-2));

  跳空高开:DRAWTEXT(VAR2,(LOW)*(0.995),‘高开’),CoLorFEBAF5;

  跳空低开:DRAWTEXT(VAR3,(HIGH)*(1.015),‘低开’),CoLor00FF00;

  VARA:=100-((90)*(HHV(HIGH,21)-CLOSE))/(HHV(HIGH,21)-LLV(LOW,21));

  VARB:=100-((90)*(HHV(HIGH,21)-CLOSE))/(HHV(HIGH,21)-LLV(LOW,21));

  VARC:=100-MA(((100)*(HHV(HIGH,6)-CLOSE))/(HHV(HIGH,6)-LLV(LOW,6)),34);

  DRAWTEXT(CROSS(VARB,MA(VARC,6)),(LOW)*0.995,‘B’),CoLor208FFF;

  DRAWTEXT(CROSS(HIGH,年) AND CROSS(VARB,MA(VARC,6)),(LOW)*0.995,‘B’),CoLor00FFFF;

  DRAWTEXT(CROSS(年,LOW) AND (CLOSE《=年),(HIGH)*1.015,‘S’),CoLorFFFF00;

  {------------------ ------------------};

  YC:=REF(CLOSE,1);

  止损价位:(YC*1.0035*97+0.1)/99.65,COLORRED,LINETHICK0;

  DRAWTEXTREL(10,30,‘上市日期:’+NUMTOSTRN(REF(YEAR,BARSCOUNT(C)-1),0)+‘年’+NUMTOSTRN(REF(MONTH,BARSCOUNT(C)-1),0)+‘月’+NUMTOSTRN(REF(DAY,BARSCOUNT(C)-1),0)+‘日’),COLOR00ffff,LINETHICK2;DRAWTEXTREL(800,920,‘**’),Colorffffff,LINETHICK2;

  WW:=BARSLAST(DISPSTATUS=1);

  DRAWTEXTREL(250,30,‘◇目前可见K线:’+NUMTOSTRN(WW+1,0)+‘天’),COLORYELLOW,LINETHICK2;

  M1:=3;

  M2:=19;

  JJ:=(CLOSE+HIGH+LOW)/3;

  A:=EMA(JJ,10);

  B:=REF(A,1);

  STICKLINE(A》B ,A ,B ,10 ,0 ),COLOR0000FF;

相关信息