大智慧K均线形态主图指标公式


  MA13:MA(C,13),COLORWHITE;

  MA34:MA(C,34),COLORYELLOW;

  MA55:MA(C,55),COLORMAGENTA;

  MA110:MA(C,110),COLORFFCC66;

  TJTS1:=BARSTATUS=2 and c《200;

  k2:=hhv(h,barslast(DISPSTATUS=1)+1);

  均线互换:=BARSLAST(REF(CROSS(MA55,MA34),1)) AND CROSS(MA34,MA55);

  DRAWTEXT(均线互换,L-0.09,‘均线互换’),COLOR0099FF;

  梅开二度:=BARSLAST(REF(CROSS(MA34,MA13),1)) AND CROSS(MA13,MA34) AND MA55《MA34;

  DRAWTEXT(梅开二度,L-0.09,‘梅开二度’),COLORWHITE;

  三线推进:=MA13》=REF(MA13,3) AND MA34》=REF(MA34,1) AND MA55》=REF(MA55,1) AND CROSS(C,MA13) AND CROSS(C,MA34) AND CROSS(C,MA55);

  DRAWTEXT(三线推进 AND FILTER(三线推进,10),L-0.09,‘三线推进’),COLORFFC8FF;

  Y:=(MA(C,13)-MA(C,55))/MA(C,13)*100;

  YY1:=C》MA(C,13) AND OPEN《MA(C,13);

  YY3:=C》MA(C,34) AND OPEN《MA(C,34);

  YY5:=C》MA(C,55) AND OPEN《MA(C,55);

  一阳三线:=YY1 AND YY5 AND YY3;

  DRAWTEXT(一阳三线,LOW-0.1,‘一阳三线’),COLORRED;

  SJ1:=ABS(MA(CLOSE,13)-MA(CLOSE,34))《C*0.01;

  SJ2:=ABS(MA(CLOSE,34)-MA(CLOSE,55))《C*0.01;

  SJ3:=CROSS(MA(CLOSE,13),MA(CLOSE,55));

  三军集合:=SJ1 AND SJ2 AND SJ3;

  DRAWTEXT(三军集合,HIGH+0.1,‘三军集合’),COLORRED;

  HK1:=CROSS(MA(C,13),MA(C,55));{13线上穿55线}

  HK2:=C《O;{当日收阴}

  HK3:=ABS(L-MA(C,13))《C*0.03 OR ABS(C-MA(C,13))《C;{收盘价或最低价在11线}

  黑客点击:=HK1 AND HK2 AND HK3 AND C》=MA(C,13) AND V《=ma(V,5);

  DRAWTEXT(黑客点击,LOW,‘黑客点击’),COLORGREEN;

  JG1:=ABS(MA(C,13)-MA(C,34))《C*0.02;

  JG2:=V》=MA(V,13);

  JG3:=OPEN《C AND C/O》1.05; {阳线5%} ;

  JG4:=O》MA(C,13) AND C》MA(C,34) AND C》MA(C,55);

  揭竿而起:=JG1 AND JG2 AND JG3 AND JG4 AND ABS(MA(C,13)-MA(C,55))《C*0.02;

  DRAWTEXT(揭竿而起,LOW-0.2,‘揭竿而起’),COLORYELLOW;

  HY1:=CROSS(MA(C,13),MA(C,55));{13线上穿55线}

  HY2:=OPEN《C AND C/O》1 AND C》=MA(C,13); {阳线3%}

  红衣侠女:=HY1 AND HY2 ;

  DRAWTEXT(红衣侠女,LOW,‘红衣侠女’),COLORRED;

  TS1:=CROSS(MA(C,13),MA(C,34));{13线上穿34线}

  TS2:=MA(C,13)《MA(C,55);

  投石问路:=TS1 AND TS2 AND MA(C,55)》C;

  DRAWTEXT(投石问路,LOW-0.2,‘投石问路’),COLORF00FF0;

  Var1K:=AMOUNT/VOL/100;

  Var2K:=MAX(ABS(HIGH-Var1K),ABS(Var1K-LOW));

  Var3K:=ABS((OPEN+CLOSE)/2-Var1K);

  MV:=(Var2K+Var3K)/Var1K*100;

  解盘A:=‘『异动测度』’+

  IFS(MV》=0 AND MV《3,‘常态区,股价波动不大,庄家没有活动。’,‘’)+

  IFS(MV》=3 and MV《5,‘非常态区,股价波动幅度较大,庄家开始活动,一般是拉升期前的准备阶段。’,‘’)+

  IFS(MV》=5 AND MV《7.5,‘超常态区,股价波动异常,一般是庄家拉升股价的开始或开始出货的信号。’,‘’)+

  IFS(MV》=7.5,‘极度区间,股价波动异常,达到极度区间的股票不多,这样的股票一般是强庄股。’,‘’);

  DRAWTEXTABS(6,40,解盘A),LINETHICK1,COLOR00ffFF;

  {均线多空解盘}

  半年线:=EMA(C,120);

  年线:=EMA(C,240);

  多空1:=MA((V/(H-L)),4);

  多空2:=ABS(C-O);

  多空3:=V/(H-L);

  TR := SUM(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(LOW-REF(CLOSE,1))),14);

  HD := HIGH-REF(HIGH,1);

  LD := REF(LOW,1)-LOW;

  DMP:= SUM(IF(HD》0 AND HD》LD,HD,0),14);

  DMM:= SUM(IF(LD》0 AND LD》HD,LD,0),14);

  PDI:= DMP*100/TR;

  MDI:= DMM*100/TR;

  ADX:= MA(ABS(MDI-PDI)/(MDI+PDI)*100,6);

  ADXR:=(ADX+REF(ADX,6))/2;

  TYP := (HIGH + LOW + CLOSE)/3;

  CCI:=(TYP-MA(TYP,14))/(0.015*AVEDEV(TYP,14));

  WR:=-100*(HHV(HIGH,14)-CLOSE)/(HHV(HIGH,14)-LLV(LOW,14));

  MTM := CLOSE-REF(CLOSE,6);

  MTMMA := MA(MTM,6);

  LC := REF(CLOSE,1);

  RSI1:=SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100;

  RSI2:=SMA(MAX(CLOSE-LC,0),12,1)/SMA(ABS(CLOSE-LC),12,1)*100;

  PSY:=COUNT(CLOSE》REF(CLOSE,1),12)/12*100;

  布林1:=(MA(CLOSE,3)+MA(CLOSE,6)+MA(CLOSE,12)+MA(CLOSE,24))/4;

  布林2:=布林1+3*STD(布林1,10);

  布林3:=布林1-3*STD(布林1,10);

  布林4:=(布林2-布林3)/布林2《0.03;

  布林5:=(布林2-布林3)/布林2》0.18;

  布林6:=(MA(C,60)-MA(C,5))/MA(C,60)》0.15;

  布林7:=(MA(C,5)-MA(C,60))/MA(C,5)》0.15;

  解盘B:=‘【均线量能解盘】’+

  IFS(C》=半年线,‘股价在半年线之上;’,‘’)+

  IFS(C》=年线,‘股价在年线之上;’,‘’)+

  IFS(C《半年线,‘股价在半年线之下;’,‘’)+

  IFS(C《年线,‘股价在年线之下;’,‘’)+

  IFS(半年线》=REF(半年线,1),‘半年线趋势向上;’,‘’)+

  IFS(年线》=REF(年线,1),‘年线趋势向上;’,‘’)+

  IFS(半年线《REF(半年线,1),‘半年线趋势向下;’,‘’)+

  IFS(年线《REF(年线,1),‘年线趋势向下;’,‘’)+

  IFS(多空3《多空1 AND 多空2《MA(多空2,4),‘资金无入场意愿,萎缩中;’,‘’)+

  IFS(多空3《多空1 AND 多空2》MA(多空2,4),‘场内资金有运作行为;’,‘’)+

  IFS(多空3》多空1 AND 多空2《MA(多空2,4),‘多空双方激烈争夺中;’,‘’)+

  IFS(多空3》多空1 AND 多空2》MA(多空2,4),‘场外资金介入(或出局)意愿强烈;’,‘’)+

  IFS(CROSS(PDI,MDI),‘PDI线从下向上突破MDI线,显示有新多头进场,为买进信号;’,‘’)+

  IFS(CROSS(MDI,PDI),‘PDI线从上向下跌破MDI线,显示有新空头进场,为卖出信号;’,‘’)+

  IFS(ADX》REF(ADX,1),‘ADX值持续高于前一日,行情将维持原趋势;’,‘’)+

  IFS(ADX《REF(ADX,1) AND ADX《20,‘ADX值递减,降到20以下,且横向行进时,市场气氛为盘整;’,‘’)+

  IFS(ADX《REF(ADX,1) AND REF(ADX,1)《REF(ADX,2) and REF(ADX,2)》REF(ADX,3) AND REF(ADX,3)》REF(ADX,4),‘ADX值从上升倾向转为下降时,表明行情即将反转;’,‘’)+

  IFS(cci《-180,‘CCI指标底位,买入机会;’,‘’)+

  IFS(cci》180,‘CCI指标高位,卖出机会;’,‘’)+

  IFS((V/CAPITAl)》0.075,‘换手过大,小心主力出逃,短期头部;’,‘’)+

  IFS(WR》-20,‘W&R超买,短线即将见顶,应及时卖出;’,‘’)+

  IFS(WR《-80,‘W&R超卖,短线即将见底,应伺机买进;’,‘’)+

  IFS(CROSS(MTM,MTMMA) and MTMMA《-0.8,‘MTM从下向上突破MTMMA,买入信号;’,‘’)+

  IFS(CROSS(MTMMA,MTM) and MTMMA》0.8,‘MTM从上向下跌破MTMMA,卖出信号;’,‘’)+

  IFS(RSI1》85,‘6日RSI超买,防止回挡;’,‘’)+

  IFS(RSI1》80,‘6日RSI向上突破85,超买,考虑卖出;’,‘’)+

  IFS(RSI1《15,‘6日RSI超卖,随时有可能反弹;’,‘’)+

  IFS(RSI1《15,‘6日RSI向下跌破15,超卖,考虑买入;’,‘’)+

  IFS(CROSS(RSI1,15),‘6日RSI向上突破15,买进信号;’,‘’)+

  IFS(CROSS(RSI1,85),‘6日RSI向下跌破85,卖出信号;’,‘’)+

  IFS(布林4,‘多空布林收敛中,有变盘的可能,上下自己分析;’,‘’)+

  IFS(布林6 AND 布林5 AND C》o ,‘布林上下乖离太大,有反弹的可能;’,‘’)+

  IFS(布林7 AND 布林5 AND C《o ,‘布林上下乖离太大,有回落的可能;’,‘’);

  DRAWTEXTABS(6,65,解盘B),LINETHICK1,COLORff00FF;

  {换手率解盘}

  {lsg 0000}

  hh:=100*v/capital;

  Var1:=ref(c,1);

  var4:=(var1-l)/(h-l);

  var5:=v*var4;

  var2:=v*var4;

  var3:=abs(var2);

  var6:=abs(var5);

  HSL:=vol/capital*100;

  PT := REF(HIGH,1)-REF(LOW,1);

  重心:=(HIGH + LOW + CLOSE)/3;

  压力Ⅰ:= 2*重心-LOW;

  压力Ⅱ:= 重心 + PT;

  支撑Ⅰ:= 2.002*重心-HIGH;

  支撑Ⅱ:= 重心 - PT;

  解盘C:=‘【换手率解盘】’+

  IFS(hh《2 AND hh》0,‘绝对地量:。成交低靡:1%—2%’,‘’)+

  IFS(hh》=2 and hh《3,‘成交温和:2%—3%’,‘’)+

  IFS(hh》=3 and hh《5,‘成交活跃:3%—5%’,‘’)+

  IFS(hh》=5 and hh《8,‘带量:5%—8%’,‘’) +

  IFS(HSL《=2,‘该股票少人关注,属于冷门股。’,‘’)+

  IFS(HSL》2 AND HSL《3,‘该股票成交温和,属于备份股。’,‘’)+

  IFS(HSL》3 AND HSL《5,‘该股票的交投越来越活跃,人们购买该股票的意愿高,属于热门股。’,‘’)+

  IFS(HSL》5 AND HSL《8,‘该股票带量!’,‘’)+

  IFS(HSL》8 AND HSL《15,‘该股票放量!’,‘’)+

  IFS(HSL》15 AND HSL《25,‘该股票巨量!’,‘’)+

  IFS(HSL》=25,‘该股票成交怪异!’,‘’);

  DRAWTEXTABS(6,90,解盘C),LINETHICK1,COLOR00FF00;

  解盘D:=‘【压力/支撑解盘】’+

  IFS(压力Ⅰ=压力Ⅰ and 压力Ⅰ》0,‘第一压力位:’+STR(压力Ⅰ),‘’)+

  IFS(支撑Ⅰ=支撑Ⅰ and 支撑Ⅰ》0,‘ #第一支撑位:’+STR(支撑Ⅰ),‘’)+

  IFS(压力Ⅱ=压力Ⅱ and 压力Ⅱ》0,‘ #第二压力位:’+STR(压力Ⅱ),‘’)+

  IFS(支撑Ⅱ=支撑Ⅱ and 支撑Ⅱ》0,‘ #第二支撑位:’+STR(支撑Ⅱ),‘’);

  DRAWTEXTABS(6,115,解盘D),LINETHICK1,COLOR00FFFF;

相关信息