大智慧顶部判断指标公式


  N := 6;

  M := 6;

  TR := SUM(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(LOW-REF(CLOSE,1))),N);

  HD := HIGH-REF(HIGH,1);

  LD := REF(LOW,1)-LOW;

  DMP:= SUM(IF(HD》0 ,HD,0),N);

  DMM:= SUM(IF(LD》0 ,LD,0),N);

  PDI: DMP*100/TR,colorwhite;

  MDI: DMM*100/TR,coloryellow;

  反转:=ref(MDI,1)=0 and ref(MDI,2)《3 and MDI》1 and close》ref(close,1) and PDI《ref(PDI,1) and ref(PDI,1)》ref(PDI,2) and PDI《60 and PDI》45;

  巨反转:=if(ref(MDI,1)=0 and ref(mdi,2)=0 AND MDI》3 AND PDI》60 and close》ref(close,1) and pdi《ref(pdi,1) and ref(close,1)》ref(close,2),1,0);

  小心:=if(ref(MDI,1)《2.5 and (MDI-ref(MDI,1))》2 and close》ref(close,1) and pdi《ref(pdi,1) and 40《PDI,1,0);

  背离:=if(close》ref(close,1) and pdi《ref(pdi,1) and ref(pdi,1)》ref(PDI,2) and ref(pdi,1)》60,1,0);

  F:=if(close》ref(close,1) and pdi《ref(pdi,1) and ref(close,2)《ref(close,1),if((PDI-10)》0,PDI-10,0),0);

  e:=if(ref(MDI,1)=0,10,0)+if(ref(MDI,1)《3,10,0)+if(ref(MDI,2)=0,10,0)+if(ref(MDI,2)《4,15,0)+if(ref(MDI,3)=0,15,0)+if(ref(MDI,3)《5,20,0)+if(MDI=0,5,0)+if(MDI《5,5,0)+F+if(F》0,ref(f,1),0);

  小心指数:IF(E》100,100,E);

  DRAWTEXT(巨反转=1,20,‘巨反转’ ),colorred;

  DRAWTEXT(巨反转=0 and 反转=1,20,‘反转’ ),colorred;

  DRAWTEXT(反转=0 and 小心=1,20,‘小心’ ),colorred;

  DRAWTEXT(背离=1,80,‘背离’),colorred;

  DRAWTEXT(背离=0 and close》ref(close,1) and pdi《ref(pdi,1) {and ref(pdi,1)》ref(PDI,2)} and ref(pdi,1)》50,70,‘背’),colorred;

  DRAWTEXT(ref(PDI,1)《2.5 and (PDI-ref(PDI,1))》1.5 and close《ref(close,1) and Mdi《ref(Mdi,1),20,‘上’ ),colorred;

  DRAWTEXT(ref(PDI,1)《5 and ref(PDI,1)《ref(pdi,2) and (PDI-ref(PDI,1))》1.5 and close》ref(close,1) and Mdi《ref(Mdi,1),20,‘?上’ ),colorred;

相关信息