飞狐指标公式:芳香自用主图指标FXQQ


{东北芳香—主图}

{庄家一般大概的成本}
Zcb1:=EMA(SUMBARS(VOL ,CAPITAL*1),5);{累计换手=100%的周期}
Zcb2:=EMA(SUM(COST(10),Zcb1)/Zcb1,5);{在A周期里获利10%的平均价}
Zcb3:=EMA(SUM(COST(20),Zcb1)/Zcb1,5);{在A周期里获利20%的平均价}
Zcb4:=EMA(SUM(COST(30),Zcb1)/Zcb1,5);{在A周期里获利30%的平均价}
Zcb5:=EMA(SUM(COST(40),Zcb1)/Zcb1,5);{在A周期里获利40%的平均价}
Zcb6:=EMA(SUM(COST(50),Zcb1)/Zcb1,5);{在A周期里获利50%的平均价}
Zcb7:=EMA((5*Zcb2+4*Zcb3+3*Zcb4+2*Zcb5+Zcb6)/15,5);{庄家大概成本}
Zcb8:=llv(Zcb7,34);
Zcb9:=IF(Zcb7<Zcb8,Zcb7,Zcb8);
{芳香趋势}
//下
FL:=MA(C,17)+ABS(MA(C,17)-REF(MA(C,17),1));
FS:=MA(C,17)+MA(C,17)-REF(MA(C,17),1);
CG:=IF(MA(C,17)<FS,FS,MA(C,17));
年线:=EMA(C,250);
A:=CG-(EMA(C,3)-CG);
QQ:=年线-(EMA(C,3)-年线);
MM:=MA(C,20);
t1:=A<=Fl; t2:=FL=FS and FS=CG; t3:=QQ<FL;
//上
DI := EMA(C,5)-EMA(C,13);
t:=MA(C,21);
q:=MA(C,34);
z:=MA(C,55);
e:=(C-(z+t+q)/3)/MA(C,3)*500;
cc:=IF(e>0,e,0);


{庄家一般大概的成本}
牛:Zcb9-(ema(c,3)-Zcb9),PRECISION2,LINETHICK2,Color8E98FF;
{芳香趋势}
PARTLINE(t1,mm*0.99),COLORYELLOW,linethick2;//下
PARTLINE(t2,mm*0.98),Color0089FF,linethick2;//下
PARTLINE(t3,mm*0.97),COLORRED,linethick2;//下
PARTLINE(t1 and cc>20,mm*1.23),COLORGREEN,linethick2;//上
PARTLINE(t2 and sum(cc,2)>78,mm*1.24),COLORGREEN,linethick2;//上
PARTLINE(t3 and sum(cc,4)>275,mm*1.25),COLORMAGENTA,linethick5;//上