飞狐公式:古道西风主图飞狐公式


飞狐的:
{古道西风主图}
DRAWGBK(CLOSE>0, COLORRGB(1,8888,8888), COLORRGB(1,3333,6666),3);
a1:=EMA((EMA(CLOSE,1)+EMA(CLOSE,3)+EMA(CLOSE,5))/3,3);
a2:=EMA((EMA(CLOSE,3)+EMA(CLOSE,5)+EMA( CLOSE,7))/3,3);
a3:=EMA((EMA(CLOSE,5)+EMA(CLOSE,7)+EMA( CLOSE,9))/3,3);
a4:=EMA((EMA(CLOSE,7)+EMA(CLOSE,9)+EMA( CLOSE,11))/3,3);
a5:=EMA((EMA(CLOSE,9)+EMA(CLOSE,11)+EMA( CLOSE,13))/3,3);
a6:=EMA((EMA(CLOSE,11)+EMA(CLOSE,13)+EMA( CLOSE,15))/3,3);
a7:=EMA((EMA(CLOSE,13)+EMA(CLOSE,15)+EMA( CLOSE,17))/3,3);
a8:=EMA((EMA(CLOSE,15)+EMA(CLOSE,17)+EMA( CLOSE,19))/3,3);
a9:=EMA((EMA(CLOSE,17)+EMA(CLOSE,19)+EMA( CLOSE,21))/3,3);
a10:=EMA((EMA(CLOSE,19)+EMA(CLOSE,21)+EMA( CLOSE,23))/3,3);
a11:=EMA((EMA(CLOSE,21)+EMA(CLOSE,23)+EMA( CLOSE,25))/3,3);
A:=EMA((EMA(CLOSE,29)+EMA(CLOSE,31)+EMA(CLOSE,33))/3,3),LINETHICK0;
a15:=a-(a1-a*0.997),colorFF1010;
a16:=a-(a2-a),colorff2010;
a17:=a-(a3-a),colorff3010;
a18:=a-(a4-a),colorff4010;
a19:=a-(a5-a),colorff5010;
a20:=a-(a6-a),colorff6010;
a21:=a-(a7-a),colorff7010;
a22:=a-(a8-a),colorff8010;
a23:=a-(a9-a),colorff9010;
a24:=a-(a10-a),colorffc010;
a25:=a-(a11-a*0.997),colorffe010;
FILLRGN(A9>A,A9,A),color436873;
FILLRGN(A9<A,A9,A),color436873;
FILLRGN(A23<A,A,A23),color4D635A;
FILLRGN(A23>A,A,A23),color4D635A;
PARTLINE(1,a15),colorFF1010;PARTLINE(1,a16),colorFF2010;
PARTLINE(1,a17),colorFF3010;PARTLINE(1,a18),colorFF4010;
PARTLINE(1,a19),colorFF5010;PARTLINE(1,a20),colorFF6010;
PARTLINE(1,a21),colorFF7010;PARTLINE(1,a22),colorFF8010;
PARTLINE(1,a23),colorFF9010;PARTLINE(1,a24),colorFFc010;
PARTLINE(1,a25),colorFFe010;
PARTLINE(1,a1),color1010FF;PARTLINE(1,a2),color1020FF;
PARTLINE(1,a3),color1030FF;PARTLINE(1,a4),color1040FF;
PARTLINE(1,a5),color1050FF;PARTLINE(1,a6),color1060FF;
PARTLINE(1,a7),color1070FF;PARTLINE(1,a8),color1080FF;
PARTLINE(1,a9),color1090FF;PARTLINE(1,a10),color10c0FF;
PARTLINE(1,a11),color10e0FF;
a:=(3*CLOSE+LOW+OPEN+HIGH)/6;
中轴:MA(CLOSE,21),colorffcc33,;
压力:中轴 + 2*STD(CLOSE,21),COLORRED,linethick2;
支撑: 中轴 - 2*STD(CLOSE,21),COLORRED,linethick2;
DRAWICON(CLOSE>=MA(CLOSE,20),MA(CLOSE,20),10);
DRAWICON(CLOSE<MA(CLOSE,20),MA(CLOSE,20),11);
FD:=(HIGH-LOW)/3;
OPEN1:=OPEN>FD*2+LOW;
OPEN3:=OPEN<FD+LOW;
OPEN2:=NOT(OPEN1 OR OPEN3);
CLOSE1:=CLOSE>FD*2+LOW;
CLOSE3:=CLOSE<FD+LOW;
CLOSE2:=NOT(CLOSE1 OR CLOSE3);
DFZD:=CLOSE1 OR (OPEN3 AND CLOSE2);
WQS1:=OPEN2 AND CLOSE2;
KFZD:=NOT(DFZD OR WQS1);
ZD:=(HIGH+LOW)/2;
QSXS:=ZD>REF(HIGH,1);
QSXX:=ZD<REF(LOW,1);
WQS2:=NOT(QSXS OR QSXX);
ZTDL:=VOL>REF(VOL,1)*1.1 OR AMOUNT>REF(AMOUNT,1)*1.5;
FTDL:=VOL<REF(VOL,1)*0.7 OR AMOUNT<REF(AMOUNT,1)*0.5;
ZTDL2:=ZTDL AND FTDL<1;
FTDL2:=FTDL AND ZTDL<1;
MFI1:=(HIGH-LOW)/(VOL/10000);
MFI2:=(HIGH-LOW)/(AMOUNT/1000000);
ZMFI1:=MFI1>REF(MFI1,1);
ZMFI2:=MFI2>REF(MFI2,1);
ZMFI:=ZMFI1 OR ZMFI2;
FMFI:=NOT(ZMFI);
LD:=ZTDL2 AND ZMFI;
ST:=FTDL2 AND FMFI;
WZ:=FTDL2 AND ZMFI;
QF:=ZTDL2 AND FMFI;
A1:=REF(HIGH,2);
A2:=FILTER(HHV(HIGH,5)=A1,2);
A3:=BACKSET(A2,3);
A4:=IF(FILTER(A3,2),HIGH,0);
A5:=SUM(A4,3);
C1:=REF(LOW,2);
C2:=FILTER(LLV(LOW,5)=C1,2);
C3:=BACKSET(C2,3);
C4:=IF(FILTER(C3,2),LOW,0);
C5:=SUM(C4,3);
XHWZ1:=HIGH*1.003;
XHWZ2:=LOW*0.998;
XHWZ3:=IF(QSXX,XHWZ2,IF(QSXS,XHWZ1,IF(DFZD,XHWZ1,XHWZ2)));
XHWZ4:=IF(ZD<REF(ZD,1),XHWZ2,XHWZ1);
S1:=DFZD AND QSXS ;
S2:=KFZD AND QSXX ;
S3:=DFZD AND QSXX;
S4:=KFZD AND QSXS;
S5:=DFZD AND WQS2;
S6:=KFZD AND WQS2;
S7:=WQS1 AND (QSXS OR QSXX OR WQS2);
STICKLINE(1,LOW,HIGH,0.5,0 ),COLOR00FFFF;
STICKLINE(S2 ,CLOSE ,OPEN,7,0 ),COLORFF2020;
STICKLINE(S1,CLOSE,OPEN,7 ,0 ),COLOR2020FF;
STICKLINE(S3,CLOSE,OPEN,7,0),COLORYELLOW;
STICKLINE(S4,CLOSE,OPEN,7,0),COLORCYAN;
STICKLINE(S5,CLOSE,OPEN,7,0),COLORMAGENTA;
STICKLINE(S6,CLOSE,OPEN,7,0),COLORGREEN;
STICKLINE(S7,CLOSE,OPEN,7,0),COLORGRAY;
STICKLINE(1,CLOSE,OPEN,2,0),COLORWHITE;
STICKLINE(LD,XHWZ3,XHWZ3*0.999,3,0),COLORGREEN;
STICKLINE(ST,XHWZ3,XHWZ3*0.999,3,0),COLORMAGENTA;
STICKLINE(WZ,XHWZ3,XHWZ3*0.999,3,0),COLORYELLOW;
STICKLINE(QF,XHWZ3,XHWZ3*0.999,3,0),COLORRED;
STICKLINE(A5>0.1,A5,A5*1.0001,6,0);
STICKLINE(C5>0.1,C5,C5*1.0001,6,0);