飞狐主图指标唯我独尊飞狐公式


飞狐主图指标--"唯我独尊",转给大家参考(有未来函数,慎用)!
源码:

{n1=30 n2=17 n3=5}
{震仓}
Var1:=EMA(CLOSE,N1)-EMA(CLOSE,N2);
Var2:=EMA(Var1,N3);
zc:=CROSS(Var1,Var2) AND TROUGHBARS(3,7,1)<1;
DRAWTEXT(zc,h+0.2,'㊣'),coloryellow,align0;
DRAWTEXT(zc,l,'震仓*'),coloryellow,align0;

空:=eMA(C,1);
多:=emA(C,5);
x:if(空>=多,多,空);
partline(空>多,x),colorred,linethick2;
partline(空<多,x),colorgreen,linethick2;
partline(空<多,多),LINETHICK2,colorgreen;
{转向}
中:=ema(c,21);
转向:=REF(中,1);
x1:=(3*C+H+L+O)/6;
x2:=EMA(x1,10);
x3:=REF(x2,1);
partline(x2>x3,转向),circledot,LINETHICK5,colorred;
partline(x2<x3,转向),circledot,LINETHICK5,colorgray;
{趋势线}
Var1:=BACKSET(REF(HIGH,2)=HHV(HIGH,5),3);
Var2:=CROSS(Var1,0.9);
Var3:=BACKSET(REF(LOW,2)=LLV(LOW,5),3);
Var4:=CROSS(Var3,0.9);
Var5:=IF(Var2,HIGH,IF(Var4,LOW,0));
趋势线:=zig(3,6),COLORAAAAAA;
DRAWTEXT(CROSS(REF(ZIG(3,6),1),ZIG(3,6)),HIGH*1.008,'跑*') ,align0, COLORgray,linethick1;
DRAWTEXT(CROSS(ZIG(3,6),TROUGHBARS(3,6,1)),HIGH*1.008,'加仓*') ,align0, COLOryellow,linethick1;

Var6:=BACKSET(REF(HIGH,2)=HHV(HIGH,5) AND LOW<REF(LOW,1) AND HIGH<REF(HIGH,1),3);
Var7:=BACKSET(REF(HIGH,2)=HHV(HIGH,5) AND LOW>REF(LOW,1) AND HIGH>REF(HIGH,1),3);
Var8:=BACKSET(REF(HIGH,2)=HHV(HIGH,5) AND HIGH<REF(HIGH,1) AND LOW>REF(LOW,1)
AND REF(LOW,1)>REF(LOW,2) AND REF(HIGH,1)<REF(HIGH,2),3);
Var9:=BACKSET(REF(LOW,2)=LLV(LOW,5) AND LOW>REF(LOW,1) AND HIGH>REF(HIGH,1),3);
VarA:=BACKSET(REF(LOW,2)=LLV(LOW,5) AND LOW<REF(LOW,1) AND HIGH<REF(HIGH,1),3);
VarB:=BACKSET(REF(LOW,2)=LLV(LOW,5) AND HIGH<REF(HIGH,1) AND LOW>REF(LOW,1)
AND REF(LOW,1)>REF(LOW,2) AND REF(HIGH,1)<REF(HIGH,2),3);
压力: REF(HIGH,BARSLAST(Var2)), POINTDOT,ColorEA91B5;
STICKLINE(CLOSE,REF(HIGH,BARSLAST(Var2)),REF(HIGH,BARSLAST(Var2)),5,0),ColorEA91B5;
支撑: REF(LOW,BARSLAST(Var4)), POINTDOT,Color00b4ff;
sTICKLINE(CLOSE,REF(LOW,BARSLAST(Var4)),REF(LOW,BARSLAST(Var4)),5,0),Color00b4ff;
现价:CLOSE,POINTDOT,Color000F89;
drawtext(barpos=sysparam(2),h,'\n所属块:'+BLKNAME),ALIGN4,COLORYELLOW;

drawtext((TROUGHBARS(3,15,1)=0) AND (HIGH>LOW+0.01),l-0.2,'买'),align0,colorred;;