股票公式:乾坤线主图(飞狐)效果不错


{乾坤线主图 AA:5 1 100 BB:15 1 100 M2:3 1 100 M22:8 1 100}
MA13:MA(C,13),COLORWHITE,LINETHICK2;
MA21:MA(C,21),COLORFFCCCC,LINETHICK2;
MA34:MA(C,34),COLORFF00FF,LINETHICK2;
MA120:MA(C,120),COLOR0099FF;
MA250:MA(C,250),COLORFFCC66;
MID:=MA(CLOSE,20);
UPPER:=MID+2*STD(CLOSE,20);
LOWER:=MID-2*STD(CLOSE,20);
V1:=(CLOSE-LOWER)/(UPPER-LOWER)*100;
V2:=V1-EMA(V1,5);
K1:=SUM(LLV(V2,4),4)/4;
V3:=EMA(V2,64)*10;
V4:=EMA(0.4*V2*(-1),3);
V5:=-1*EMA(V2,39)*10;
A:=V3>10;
B:=V2>V4;
D:=V5>10;
E:=V3<=10 OR V2<=V4 OR V5<=10;
KS:=(CLOSE-SMA(CLOSE,13,1))/SMA(CLOSE,13,1)*(-100);
RKS:=REF(KS,1);
MLS:=RKS/KS>1.23 AND RKS>13 AND CLOSE/REF(CLOSE,1)>1.03;
开:=OPEN;
高:=HIGH;
低:=LOW;
收:=CLOSE;
STICKLINE(收>=开 AND E,高,低,0,0),COLORred;
STICKLINE(收>=开 AND E,收,开,6,0),COLORred;
STICKLINE(收< 开 AND E,高,低,0,0),COLORgreen;
STICKLINE(收< 开 AND E,收,开,6,0),COLORgreen;
STICKLINE(开> 收 AND A,低,高,0,0),COLORYELLOW;
STICKLINE(开> 收 AND A,收,开,6,0),COLORYELLOW;
STICKLINE(开<=收 AND A,低,高,0,0),COLORYELLOW;
STICKLINE(开<=收 AND A,收,开,6,1),COLORYELLOW;
STICKLINE(开> 收 AND B,低,高,0,0),COLORRED;
STICKLINE(开> 收 AND B,收,开,6,0),COLORRED;
STICKLINE(开<=收 AND B,低,高,0,0),COLORRED;
STICKLINE(开<=收 AND B,收,开,6,1),COLORRED;
STICKLINE(开> 收 AND D,低,高,0,0),COLORGREEN;
STICKLINE(开> 收 AND D,收,开,6,0),COLORGREEN;
STICKLINE(开<=收 AND D,低,高,0,0),COLORGREEN;
STICKLINE(开<=收 AND D,收,开,6,1),COLORGREEN;
超跌:STICKLINE(KS>13,高,低,0,1),colorwhite,linethick2;
反弹:STICKLINE(MLS=1,高,低,0,1),colormagenta,linethick2;
STICKLINE(KS>13,开,收,8,1),colorwhite,linethick2;
STICKLINE(MLS=1,开,收,8,1),colormagenta,linethick2;
tj1:=SLOPE(EMA(CLOSE,2),aa)*bb+CLOSE ;
s:=EMA(SLOPE(CLOSE,5)/REF(CLOSE,14),3)*302 ;
t1:=BARSLAST(CROSS(CLOSE,KS));
t2:=BARSLAST(CROSS(KS,CLOSE));
红跟入:STICKLINE(CLOSE>KS ,REF(CLOSE,t1),REF(CLOSE,t1),1,0),linethick6,colorred;
黄洗盘:STICKLINE(CLOSE>KS and CLOSE<REF(CLOSE,t1),REF(CLOSE,t1),REF(CLOSE,t1),1,0),linethick6,coloryellow;
蓝下跌:STICKLINE(CLOSE<KS,REF(CLOSE,t2),REF(CLOSE,t2),1,0),linethick6,COLORCYAN;
鄂:REF(CLOSE,t1),colorblue;
圆圈:REF(CLOSE,t2),colorwhite;