操盘均线主图公式


  通达信股票高位提示S的卖出指标源码:操盘均线主图公式

  MA5:MA(CLOSE,5);

  MA10:MA(CLOSE,10),COLORYELLOW;

  MA30:MA(CLOSE,30),COLORFFCC66;

  AA5:=(ATAN((MA(C,5)/REF(MA(C,5),1)-1)*100)*180/3.14115926)》60;

  AA6:=(ATAN((MA(C,10)/REF(MA(C,10),1)-1)*100)*180/3.14115926)》45;

  AA7:=(ATAN((MA(C,30)/REF(MA(C,30),1)-1)*100)*180/3.14115926)》15;

  角度60MA5:IF(AA5,MA5,DRAWNULL),COLORRED;

  角度45MA10:IF(AA6,MA10,DRAWNULL),COLORRED;

  角度15MA30:IF(AA7,MA30,DRAWNULL),COLORRED;

  下降MA5:IF(MA5《REF(MA5,1),MA5,DRAWNULL),COLORGREEN;

  下降MA10:IF(MA10《REF(MA10,1),MA10,DRAWNULL),COLORGREEN;

  下降MA30:IF(MA30《REF(MA30,1),MA30,DRAWNULL),COLORGREEN;

  金叉1:=CROSS(MA5,MA10) AND MA10》REF(MA10,1) AND MA5》REF(MA5,1);

  死叉:=CROSS(MA10,MA5);

  STICKLINE(金叉1,LOW,LOW*0.97,1,0),COLORFF00FF;

  DRAWTEXT(死叉,H+0.13,‘S’),COLORD9D919;

  AR1:=MA30》MA10 AND MA10》MA5;

  AR2:=BARSLAST((C-MA5)/MA5*100《-6);

  AR3:=MA5》=REF(MA5,1);

  AR4:=COUNT(CROSS(C,MA5),AR2)=1;

  AR5:=AR1 AND AR2 AND AR3 AND AR4;

  AR6:=AR5 AND FILTER(AR5,10);

  STICKLINE(AR6,O,C,2.5,0),LINETHICK2,COLORYELLOW;

  BOLL:=MA(CLOSE,20);

  UPPER:BOLL+2*STD(CLOSE,20),POINTDOT,COLORYELLOW,LINETHICK3;

  LOWER:BOLL-2*STD(CLOSE,20),POINTDOT,COLORYELLOW,LINETHICK3;

  AA:=(REF(C,1)+REF(C,2)+O)/3;

  今日保护价:=AA,COLORD9D919;