通达信战略家蓝黄丝带免费源码主图公式下载


  通达信战略家蓝黄丝带免费源码主图公式下载

  {参数: N:0/150/20; N1:0/120/7; N2:0/1100/79}

  JJ:=(CLOSE+HIGH+LOW)/3;

  A:=EMA(JJ,10);

  B:=REF(A,1);

  STICKLINE(A》B,A,B,5,0),COLORYELLOW;

  STICKLINE(A《B,A,B,5,0),COLORBLUE;

  MA5:MA(C,5),COLORRED,LINETHICK2;

  M13:EMA(CLOSE,13);

  M34:EMA(M13,34);

  M55:EMA(M13,55);

  VAR1:=EMA(M34,55);

  M105:EMA(M55,105);

  M240:EMA(VAR1,240), COLORRED,LINETHICK2;

  VAR2:=(REF(HIGH,1)+REF(LOW,1))/2;

  VAR3:=MA(CLOSE,N)+2*STD(CLOSE,N);

  {DRAWICON(CROSS(VAR2,VAR3),HIGH*1.035,2);}

  {DRAWTEXT(CROSS(VAR2,VAR3),HIGH*1.02,‘卖出’), COLORGREEN;}

  VAR4:=REF(CLOSE,1);

  VAR5:=SMA(MAX(CLOSE-VAR4,0),N1,1)/SMA(ABS(CLOSE-VAR4),N1,1)*100;

  VAR6:=CROSS(N2,VAR5);

  VAR7:=FILTER(VAR6,4);

  {DRAWICON(VAR7,HIGH*1.035,2);}

  {DRAWTEXT(VAR7,HIGH*1.02,‘卖出’), COLORGREEN;}

  A7:=(2*C+H+L)/4;

  VAR10:=LLV(LOW,34);

  VAR11:=HHV(HIGH,34);

  SK:=EMA((A7-VAR1)/(VAR2-VAR1)*100,7);

  SD:=EMA(0.667*REF(SK,1)+0.333*SK,5);

  DRAWTEXT(IF(COUNT(CLOSE《REF(CLOSE,1),8)/8》6/10 AND VOL》=1.5*MA(VOL,5) AND

  COUNT(SK》=SD,3) AND REF(LOW,1)=LLV(LOW,120),1,0),LOW,‘●买进’) ,COLORRED;

  DRAWTEXT(IF(COUNT(CLOSE《REF(CLOSE,1),13)/13》6/10 AND

  COUNT(SK》SD,6) AND REF(LOW,5)=LLV(LOW,120) AND REF(CLOSE》=OPEN,4) AND

  REF(CLOSE》OPEN,3) AND REF(CLOSE》OPEN,2) AND REF(OPEN》CLOSE,1) AND

  OPEN》REF(CLOSE,1),1,0),LOW,‘●买进’), COLORRED;

  D:=MA(CLOSE,80)-MA(CLOSE,10)/3;

  DRAWTEXT(IF(CLOSE《D AND VOL/240》MA(VOL,5)/240 AND CLOSE》REF(CLOSE,1)*1.08

  AND CLOSE《MA(CLOSE,13)*1.3,1,0),LOW,‘●抄底’),COLORRED;

  STICKLINE(CLOSE》 REF(CLOSE,1) ,HIGH,LOW,0,1 ),COLORRED;

  STICKLINE(CLOSE》 REF(CLOSE,1) ,OPEN,CLOSE,3.1,0 ),COLOR000033;

  STICKLINE(CLOSE》 REF(CLOSE,1) ,OPEN,CLOSE,2.7,0 ),COLOR000066;

  STICKLINE(CLOSE》 REF(CLOSE,1) ,OPEN,CLOSE,2.1,0 ),COLOR000099;

  STICKLINE(CLOSE》 REF(CLOSE,1) ,OPEN,CLOSE,1.5,0 ),COLOR0000CC;

  STICKLINE(CLOSE》 REF(CLOSE,1) ,OPEN,CLOSE,0.9,0 ),COLOR0000FF;

  STICKLINE(CLOSE》 REF(CLOSE,1) ,OPEN,CLOSE,0.3,0 ),COLORCC66FF;

  STICKLINE(CLOSE《 REF(CLOSE,1) ,HIGH,LOW,0,1 ),COLORCYAN;

  STICKLINE(CLOSE《 REF(CLOSE,1) ,OPEN,CLOSE,3.1,0 ),COLOR990000;

  STICKLINE(CLOSE《 REF(CLOSE,1) ,OPEN,CLOSE,2.7,0 ),COLORCC0000;

  STICKLINE(CLOSE《 REF(CLOSE,1) ,OPEN,CLOSE,2.1,0 ),COLORFF4400;

  STICKLINE(CLOSE《 REF(CLOSE,1) ,OPEN,CLOSE,1.5,0 ),COLORFF8800;

  STICKLINE(CLOSE《 REF(CLOSE,1) ,OPEN,CLOSE,0.9,0 ),COLORFFCC00;

  STICKLINE(CLOSE《 REF(CLOSE,1) ,OPEN,CLOSE,0.3,0 ),COLORCYAN;

  STICKLINE(CLOSE= REF(CLOSE,1) ,HIGH,LOW,0,1 ),COLORWHITE;

  STICKLINE(CLOSE= REF(CLOSE,1) ,OPEN,CLOSE,3.1,0 ),COLOR555555;

  STICKLINE(CLOSE= REF(CLOSE,1) ,OPEN,CLOSE,2.7,0 ),COLOR777777;

  STICKLINE(CLOSE= REF(CLOSE,1) ,OPEN,CLOSE,2.1,0 ),COLOR999999;

  STICKLINE(CLOSE= REF(CLOSE,1) ,OPEN,CLOSE,1.5,0 ),COLORBBBBBB;

  STICKLINE(CLOSE= REF(CLOSE,1) ,OPEN,CLOSE,0.9,0 ),COLORDDDDDD;

  STICKLINE(CLOSE= REF(CLOSE,1) ,OPEN,CLOSE,0.3,0 ),COLORFFFFFF;

  KU1:=IF(HIGH=HHV(HIGH,3),1,0);

  KD1:=IF(LOW=LLV(LOW,3),1,0);

  UL:=IF(REF(KU1,2)=1 AND REF(KU1,1)=0

  AND KU1=0,REF(HIGH,2),REF(HIGH,2+BARSLAST(REF(KU1,2)=1

  AND REF(KU1,1)=0 AND KU1=0)));

  DL:=IF(REF(KD1,2)=1 AND REF(KD1,1)=0

  AND KD1=0,REF(LOW,2),REF(LOW,2+BARSLAST(REF(KD1,2)=1

  AND REF(KD1,1)=0 AND KD1=0)));

  HV:=H》UL AND H》REF(H,1) ;

  LV:=L《DL AND L《REF(L,1) ;

  GP:=BARSLAST(HV);

  DP:=BARSLAST(LV);

  IP:=IF(GP=0,DP,GP)》3;

  HV1:=HV AND IP AND H》=HHV(H,BARSLAST(LV));

  LV1:=LV AND IP AND L《=LLV(L,BARSLAST(HV));

  {DRAWLINE(LV1,LOW,HV1, HIGH,0),COLORGRAY;

  DRAWLINE(HV1,HIGH,LV1, LOW,0),COLORGRAY;}

  DRAWLINE(LV1,LOW,HV1, HIGH,0),COLORWHITE,LINETHICK2;

  DRAWLINE(HV1,HIGH,LV1, LOW,0),COLORWHITE,LINETHICK2;