通达信用QQ表情表示股票压力位、支撑位的主图源码公式


  通达信用QQ表情表示股票压力位、支撑位的主图源码公式

  支撑价:LLV(LOW,19),LINETHICK2 , COLOR00FF00;

  阻力价:HHV(HIGH,19),COLORBLUE, LINETHICK2;

  VAR1:=EMA(CLOSE,12)-EMA(CLOSE,26);

  VAR2:=EMA(VAR1,9);

  VAR3:=(CLOSE*2.5/100+CLOSE);

  VAR4:EMA(C,3);

  VAR5:=LLV(HIGH,240);

  VAR6:=100*(CLOSE-VAR5)/VAR5;

  VAR7:=REF(LLV(CLOSE,480),1);

  VAR8:=REF(HHV(CLOSE,480),1);

  VAR9:=100*(CLOSE-VAR7)/(VAR8-VAR7);

  VARA:=(CLOSE-LLV(CLOSE,981))/(HHV(CLOSE,981)-LLV(CLOSE,981))*100;

  VARB:=(CLOSE-LLV(CLOSE,393))/(HHV(CLOSE,393)-LLV(CLOSE,393))*100;

  VARC:=(CLOSE-LLV(LOW,981))/(HHV(HIGH,981)-LLV(LOW,981))*100;

  VARD:=(CLOSE-LLV(LOW,393))/(HHV(HIGH,393)-LLV(LOW,393))*100;

  VARE:=VARC》98.5 OR VARD》98.5;

  VARF:=EMA(100*(CLOSE-LLV(LOW,100))/(HHV(HIGH,100)-LLV(LOW,100)),5)/4;

  VAR13:=VARA=0 AND VARC=0 AND VAR6《0;

  VAR14:=VARA=100 AND VARC=100;

  VAR15:=VARB=0 OR VARD=0 AND VAR9《0;

  VAR16:=VARB=100 AND VARD=100;

  VAR17:=VAR6《0 AND VAR9《0;

  VAR18:=VAR13 AND VAR15;

  VAR19:=VAR14 AND VAR16;

  VAR1B:=SMA(MAX(CLOSE-REF(CLOSE,1),0),49,1)/SMA(ABS(CLOSE-REF(CLOSE,1)),6,1)*100;

  VAR1C:=SMA(MAX(CLOSE-REF(CLOSE,1),0),14,1)/SMA(ABS(CLOSE-REF(CLOSE,1)),14,1)*100;

  VAR1D:=BARSCOUNT(CLOSE);

  VAR1E:=VAR1B《20 AND VAR1C《23 AND VAR1D》35;

  VAR1F:=VAR1E AND COUNT(VAR1E,1)=1;

  VAR20:=REF(CLOSE,1);

  VAR21:=SMA(MAX(CLOSE-VAR20,0),34,1)/SMA(ABS(CLOSE-VAR20),7,1)*100;

  VAR22:=SMA(MAX(CLOSE-VAR20,0),13,1)/SMA(ABS(CLOSE-VAR20),13,1)*100;

  VAR23:=BARSCOUNT(CLOSE);

  VAR24:=VAR21《20 AND VAR22《23 AND VAR23》35;

  VAR25:=VARA=0 AND VARF《1.2 AND VAR17;

  VAR27:=VAR18 AND VARF《1.2 AND VAR17;

  VAR29:=SUM(HIGH-OPEN,77)/SUM(OPEN-LOW,77)*100;

  VAR2A:=SUM(MAX(0,HIGH-REF(CLOSE,1)),77)/SUM(MAX(0,REF(CLOSE,1)-LOW),77)*100;

  VAR2B:=CROSS(VAR29,69) AND CROSS(VAR2A,80)《150;

  VAR2C:=VAR24 AND VAR1F AND COUNT(VAR24,30)=1;

  买点:=VAR25 AND VAR2B;

  绝对卖点:=(VAR19 OR VARA)AND VARF》23 OR VARE ;

  VAR2D:=VAR1F AND VAR2C AND VAR25;

  股海万元户:=(CLOSE/REF(CLOSE,1)》1.04 AND (CLOSE》10.8 AND CLOSE《10.83 OR CLOSE》6.86 AND CLOSE《6.88 OR CLOSE》13.82 AND CLOSE《13.84 OR CLOSE》7.28 AND CLOSE《7.3 OR CLOSE》12.4 AND CLOSE《12.42 OR CLOSE》22.33 AND CLOSE《22.35 OR CLOSE》4.68 AND CLOSE《4.7 OR CLOSE》26.29 AND CLOSE《26.31 OR CLOSE》7.65 AND CLOSE《7.67 OR CLOSE》13.4 AND CLOSE《13.42 OR CLOSE》7.58 AND CLOSE《7.6 OR CLOSE》20.43 AND CLOSE《20.45 OR CLOSE》19.57 AND CLOSE《19.59 OR CLOSE》6.26 AND CLOSE《6.28 OR CLOSE》7.14 AND CLOSE《7.16 OR CLOSE》6.61 AND CLOSE《6.63 OR CLOSE》11.9 AND VOL《11.92 OR CLOSE》6.7 AND CLOSE《6.72 OR CLOSE》8.19 AND CLOSE《8.21));

  DRAWTEXT(FILTER(绝对卖点》0,3),H,‘别贪’), COLOR00FF00;

  DRAWTEXT(股海万元户》0,L,‘☆追涨’),COLORYELLOW ;

  DRAWICON(买点》0,L,4);

  DRAWTEXT(买点》0,L,‘扫描神针’),COLORF00FF0;

  DRAWTEXT(VARF《0.7 AND VAR27 AND VAR25》0,L,‘万元’),COLORYELLOW;

  STICKLINE(VAR2D》0,O,C,10,0), COLORRED;

  DRAWTEXT(VAR2D》0,L,‘大方神针’),COLORRED;

  DRAWICON(COUNT(REF(VAR4,1)《REF(VAR4,2),5)=5 AND VAR4》REF(VAR4,1),L*0.98,4);

  DRAWICON(FILTER(COUNT(VAR6《0,5)AND CROSS(VAR6,0)AND VARF》REF(VARF,1)AND C》O,3),L,1);

  DRAWICON(FILTER(REF(VAR4,1)》REF(VAR4,2)AND VAR4《REF(VAR4,1)AND VARF》17 AND VAR1》VAR2,5),H,2);

  DRAWICON(阻力价》REF(阻力价,1)AND CROSS(阻力价,VAR3)AND C《O,H*1.02,5);