通达信主图提示BS买卖点的免费源码指标下载


  通达信主图提示BS买卖点的免费源码指标下载

  N:=8;

  M:=REF(CLOSE,1);

  A:=SMA(MAX(CLOSE-M,0),N,1)/SMA(ABS(CLOSE-M),N,1)*100,COLORYELLOW,LINETHICK1;

  B0:=A=DRAWLINE(A》=HHV(A,N),A,A《=LLV(A,N),1,A),COLOR00FF00;

  B1:=A=DRAWLINE(A》=HHV(A,N),A,A《=LLV(A,N),A,1),COLOR00FF00;

  B2:= A《REF(A,1);

  B3:=A》REF(1,A);

  C1:=DRAWICON(B1 AND B2,A,9);

  C2:=DRAWICON(B0 AND B3,A,15);

  DRAWICON(FILTER(C1》0,1),L*0.97,9);

  DRAWICON(FILTER(C2》0,1),H*1.02,15);

  网1:EXPMA(CLOSE,6);

  网2:MA(CLOSE,12),POINTDOT;

  网3:EXPMA(CLOSE,33),COLORFF00FF,LINETHICK3;

  IF(网3《REF(网3,1),网3,DRAWNULL),COLOR00FF00,LINETHICK3;

  VAR1111:=BACKSET(REF(HIGH,2)=HHV(HIGH,5),3);

  VAR2222:=CROSS(VAR1111,0.9);

  VAR3333:=BACKSET(REF(LOW,2)=LLV(LOW,5),3);

  VAR4444:=CROSS(VAR3333,0.9);

  压力:= REF(HIGH,BARSLAST(VAR2222));

  STICKLINE(CLOSE,REF(HIGH,BARSLAST(VAR2222)),REF(HIGH,BARSLAST(VAR2222)),0.5,1),COLOREA91B5,LINETHICK3;

  支撑:= REF(LOW,BARSLAST(VAR4444));

  STICKLINE(CLOSE,REF(LOW,BARSLAST(VAR4444)),REF(LOW,BARSLAST(VAR4444)),0.5,1),COLOR00B4FF,LINETHICK3;

  下档线:=(((CLOSE - LLV(LOW,13)) / (HHV(HIGH,13) - LLV(LOW,13))) * 100);

  RRRSV:=SMA(下档线,3,1);

  KKK:=SMA(RRRSV,3,1);

  DDD:=((3 * RRRSV) - (2 * KKK));

  JJ12:=(((CLOSE - LLV(LOW,55)) / (HHV(HIGH,55) - LLV(LOW,55))) * 100);

  RSV24:=SMA(JJ12,3,1);

  K24:=SMA(RSV24,3,1);

  D24:=((3 * RSV24) - (2 * K24));

  压力2:=IF(CROSS(D24,DDD),HIGH,REF(HIGH,BARSLAST(CROSS(D24,DDD)))),COLORFFFFFF;

  压力位:=IF(ISLASTBAR,压力2,DRAWNULL);

  STICKLINE(ISLASTBAR ,压力位,压力位,120,0),LINETHICK4,COLORFFFFFF;

  底部:=LLV(HIGH,30),COLOR00FF00;

  底部位:=IF(ISLASTBAR,底部,DRAWNULL);

  STICKLINE(ISLASTBAR ,底部位,底部位,100,0),LINETHICK4,COLOR00FF00;

  {交易指示}

  DATA:=5;

  {多头买入} DRAWICON(ZIG(3,DATA)》REF(ZIG(3,DATA),1)

  AND REF(ZIG(3,DATA),1)《=REF(ZIG(3,DATA),2)

  AND REF(ZIG(3,DATA),2)《=REF(ZIG(3,DATA),3),L*0.98,1);

  {多头卖出} DRAWICON(ZIG(3,DATA)《REF(ZIG(3,DATA),1)

  AND REF(ZIG(3,DATA),1)》=REF(ZIG(3,DATA),2)

  AND REF(ZIG(3,DATA),2)》=REF(ZIG(3,DATA),3),H*1.02,2);

  {B S}

  VAR11:=(100 - ((90 * (HHV(HIGH,14) - CLOSE)) / (HHV(HIGH,14) - LLV(LOW,14))));

  VAR21:=(100 - ((90 * (HHV(HIGH,14) - CLOSE)) / (HHV(HIGH,14) - LLV(LOW,14))));

  VAR31:=(100 - MA(((100 * (HHV(HIGH,6) - CLOSE)) / (HHV(HIGH,6) - LLV(LOW,6))),34));

  DRAWICON(CROSS(VAR21,MA(VAR31,6)),(LOW - (LOW*0.04)),7);

  DRAWICON(CROSS(MA(VAR31,6),VAR11),(HIGH+(HIGH*0.03)),8);

  {压力支撑}

  E:=(HIGH+LOW+OPEN+2*CLOSE)/5;

  AAA:=2*E-LOW,NODRAW;

  AB:=2*E-HIGH,NODRAW;

  ACC:=E+(HIGH-LOW),NODRAW;

  ADD:=E-(HIGH-LOW),NODRAW;

  今阻力:REF(AAA,1),COLORWHITE,NODRAW;

  今支撑:REF(AB,1),COLORYELLOW,NODRAW;

  明阻力:AAA,COLORCYAN,NODRAW;

  明支撑:AB,COLORMAGENTA,NODRAW;

  明突破:ACC,COLORGREEN,NODRAW;

  明反转:ADD,COLORLICYAN,NODRAW;

  GJ:=(C+H+L+O)/4;

  明日阻力:=L+(GJ-L)+(C-L);

  明日支撑:=L+(C-GJ);

  今日阻力:REF(明日阻力 , 1),NODRAW;

  今日支撑:REF(明日支撑 , 1),NODRAW;

  STICKLINE(ISLASTBAR AND C》=今日阻力,今日阻力,今日阻力,10,1),COLOR0000FF;

  STICKLINE(ISLASTBAR AND C《今日阻力,今日阻力,今日阻力,10,1),COLOR00FF00;

  STICKLINE(ISLASTBAR AND C》=今日支撑,今日支撑,今日支撑,10,1),COLORFF00FF;

  STICKLINE(ISLASTBAR AND C《今日支撑,今日支撑,今日支撑,10,1),COLORFF8800;

  {网交易}

  网11:=MA(C,1);网5:=MA(C,5); 网6:=MA(C,6);

  DRAWICON(CROSS(网1,网5),L,1);

  DRAWICON(CROSS(网6,网1),H,2);

  {提示买卖}

  阻力:REFDATE(REF(HHV(H,22),1),DATE),COLORGRAY;

  底:REFDATE(REF(LLV(L,22),1),DATE),COLORGRAY;

  网A:=XMA(XMA(XMA(EMA(C,1),2),2),2);

  DRAWTEXT(CROSS(网A,REF(网A,1)),L,‘买’),COLORFF00FF;

  DRAWTEXT(CROSS(REF(网A,1),网A),H,‘卖’),COLOR00FF00;

  {BT}

  AA:=REF(C,1);

  HH:=MAX(C,AA);

  LL:=MIN(C,AA);

  ZY:=REF(C,1)》REF(LL,1);{昨天收阳}

  ZD:=REF(C,1)《REF(HH,1);{昨天收阴}

  STICKLINE(C》=AA,LL,HH,2.7,0),COLORRED;

  STICKLINE(C《AA,LL,HH,2.7,0),COLOR008000;

  STICKLINE(ZY AND C》=REF(AA,1),LL,HH,2.7,0),COLORRED;

  STICKLINE(ZY AND C《REF(AA,1),HH,REF(AA,1),2.7,0),COLORRED;

  STICKLINE(ZY AND C《REF(AA,1),REF(AA,1),C,2.7,0),COLOR008000;

  STICKLINE(ZD AND C《=REF(AA,1),LL,HH,2.7,0),COLOR008000;

  STICKLINE(ZD AND C》REF(AA,1),LL,REF(AA,1),2.7,0),COLOR008000;

  STICKLINE(ZD AND C》REF(AA,1),REF(AA,1),C,2.7,0),COLORRED;

  MA5:EMA(CLOSE,5),COLORRED;

  S5:IF(MA5《REF(MA5,1),MA5,DRAWNULL),COLORGREEN;