通达信强弱跌涨指标公式


  N:=14;

  K:=N/2;

  DTPL:=MA(C,N)》MA(C,N*1.5) AND MA(C,N*1.5)》MA(C,N*3) AND MA(C,3)》MA(C,N*6);

  选择均线:N,POINTDOT,COLORYELLOW;

  强弱天数:K,POINTDOT,COLORFF00FF;

  连续走强:=COUNT(C》MA(C,N),K)=K;

  ZQSJ:=BARSLAST(连续走强);

  STICKLINE(连续走强 ,0 ,K*0.3 ,5 ,1 ),COLORYELLOW;

  下穿:=CROSS(MA(C,N),C);

  GL:=MA(C,N/2)/MA(C,N*2)》=1.05;

  买跌:(下穿 AND ZQSJ《=3 AND DTPL AND GL)*N,COLOR00FF00,LINETHICK2;

  连续走弱:=COUNT(C《MA(C,N),K)=K;

  ZRSJ:=BARSLAST(连续走弱);

  STICKLINE(连续走弱 ,0 ,K*-0.3 ,5 ,1 ),COLOR00FF00;

  上穿:=CROSS(C,MA(C,N));

  买涨:(上穿 AND ZRSJ《=3)*K,COLORFF00FF,LINETHICK2;

  强:连续走强*K*0.3,COLORYELLOW;

  弱:连续走弱*K*-0.3,COLOR00FF00;