通达信北沙36计主图指标公式


  说明: A、当黄色区出现后、股价回落到紫线附近、表示调整充分(但不是安全的买点); B、此后股价重新站上30天线、且有成交量的支持、此时介入、往往能赚点小菜钱;

  M30:=MA(C,30);

  M60:=MA(C,60);

  VA1:=HHVBARS(M30,BARSLAST(M30《M60)+1);

  VA2:=CROSS(BACKSET(CROSS(M60,M30),REF(VA1,1)+2),0.5);

  QG:=CROSS(BACKSET(CROSS(0,M30) OR (ISLASTBAR AND M30》M60),REF(VA1,1)+2),0.5);

  STICKLINE(M30》DRAWLINE(VA2,M30,REF(VA2,1),REF(M30,1),1),M30,DRAWLINE(VA2,M30,REF(VA2,1),REF(M30,1),1),1,0),COLOR00BBBB;

  前高:DRAWLINE(VA2,M30,REF(VA2,1),REF(M30,1),1),COLORGREEN,DOTLINE;

  JC:=CROSS(M30,M60);

  JTS:=BARSLAST(JC);

  XG1:=JTS》=0 AND M30》前高;

  SC:=CROSS(M60,M30);

  STS:=BARSLAST(SC);

  XG2:=C《REF(LLV(M30,STS),JTS+1);

  VA3:=LLVBARS(M30,BARSLAST(M30》M60)+1);

  VA4:=CROSS(BACKSET(CROSS(M30,M60),REF(VA3,1)+2),0.5);

  BD:=BARSLAST(FILTERX(CROSS(M60,M30),BARSCOUNT(C)));

  BG:=BARSLAST(FILTERX(CROSS(M30,M60),BARSCOUNT(C)));

  STICKLINE(M30《REF(LLV(M30,STS),JTS+1) AND M30《=M60,M30,REF(LLV(M30,STS),JTS+1),1,0),COLORGRAY;

  前低:DRAWLINE(VA4,M30,REF(VA4,1),REF(M30,1),1),COLORMAGENTA,DOTLINE;

  STICKLINE(XG1 AND H《前低,H*1.002,L*0.998,4,1),COLORWHITE;

  STICKLINE(XG1 AND H》前低 AND MAX(C,O)《前低,前低,L*0.998,4,1),COLORWHITE;

  STICKLINE(XG1 AND C《前低 AND O》前低,C*0.998,前低,4,1),COLORWHITE;

  信号:=CROSS(COUNT(C/REF(C,1)》1.07,BARSLAST(CROSS(XG1 AND XG2,0.5)))=1,0.5) AND CROSS(C》前低,0.5);

  STICKLINE(信号,H*1.004,L*0.998,4,0),COLORYELLOW;

  DRAWKLINE(HIGH,OPEN,LOW,CLOSE);

  DRAWICON(CROSS(M30》前高,0.5),前高,1);

  BDTJ:=IF(M30《M60,FILTERX(M30=LLV(M30,BARSLAST(M30》M60)),

  BARSCOUNT(C)),DRAWNULL);

  TSBDTJ:=BARSLAST(BDTJ);

  BDZH:=FILTERX(M30《CONST(LLV(M30,BD+1)),BARSCOUNT(C));

  BDTS:=BARSLAST(BDZH);

  本低:=IF(BD+1》=1,CONST(LLV(M30,BD+1)),DRAWNULL),COLORLIRED,DOTLINE;

  BDCL:=CROSS(COUNT(CROSS(M30》本低/2 AND M30《M60,0.5),TSBDTJ)=1,0.5) AND TSBDTJ》=0;

  终点:=IF(ISLASTBAR AND M30》0 AND M30=HHV(M30,BARSLAST(M30《M60)),1,

  IF(FILTERX(QG,BARSCOUNT(C)),2,DRAWNULL));

  UU:=(终点=1 OR 终点=2) AND M30》M60;

  ZZ:=FILTERX(UU,BARSCOUNT(C));

  本高:=IF(BG+1》=1,CONST(HHV(M30,BG+1)),DRAWNULL),COLORWHITE,DOTLINE;

  前高成立:=SUM(JC,0)》=2 AND XG1;

  DRAWTEXT(CROSS(前高成立,0.5),L*0.998,‘前高成立’);

  TT:=IF(VA4,BARSNEXT(CROSS(前高成立,0.5)),DRAWNULL);

  WW:=IF(CROSS(前高成立,0.5),REF(C,BARSLAST(VA4)),0);

  QQ:=IF(CROSS(前高成立,0.5),REF(H,BARSLAST(VA4)),0);

  QDCL:=VA4 AND C=REFX(REF(C,BARSLAST(VA4)),TT) AND H=REFX(REF(H,BARSLAST(VA4)),TT);

  DRAWTEXT(QDCL,M30,‘前低成立’);

  XX:=IF(CROSS(前高成立,0.5),REF(LLV(M30,STS),JTS+1),0);

  GG:=BARSLAST(CROSS(前高成立,0.5))》=0 AND CROSS(COUNT(C《REF(XX,

  BARSLAST(CROSS(前高成立,0.5))),BARSLAST(CROSS(前高成立,0.5)))=1,0.5);

  DRAWTEXT(FILTER(C《REF(前低,BARSLAST(GG)) AND REF(C,1)》REF(前低,BARSLAST(GG)) AND

  前低=REF(前低,BARSLAST(GG)),10),L*0.998,‘收盘成立’);

  前前低:=IF(QDCL,REF(REF(M30,BARSLAST(VA4)),1),0);

  前前低线:=IF(BARSLAST(QDCL)》=0,REF(前前低,BARSLAST(QDCL)),0);

  QDQD:=IF(BARSLAST(QDCL)》=0,REF(M30,BARSLAST(QDCL)),0);

  前前低横线:IF(COUNT(JC,BARSLAST(QDCL))《2 AND BARSLAST(QDCL)》=0 AND QDQD》前前低线,

  DRAWLINE(QDCL,REF(REF(M30,BARSLAST(VA4)),1),REF(QDCL,1),

  REF(REF(REF(M30,BARSLAST(VA4)),1),1),1),DRAWNULL),COLORRED;

  CPCLTS:=BARSLAST(FILTER(C《REF(前低,BARSLAST(GG)) AND REF(C,1)》REF(前低,BARSLAST(GG)) AND

  前低=REF(前低,BARSLAST(GG)) AND (C-REF(C,1))/REF(C,1)*100《-6,10));

  打井:CROSS(COUNT(CPCLTS》=0 AND C/REF(C,1)》=1.06 AND C》REF(H,CPCLTS),CPCLTS)=1,0.5);

  E1:=DRAWLINE(CPCLTS=0,H,打井,REF(H,CPCLTS),0),DOTLINE;

  E2:=DRAWLINE(CPCLTS=0,REFX(C,BARSNEXT(打井)),打井,C,0),DOTLINE;

  DRAWTEXT(打井,(C+REF(H,CPCLTS))/2,‘#’),COLORYELLOW;

  MA30:MA(C,30),COLORYELLOW;

  MA60:MA(C,60),COLORLIBLUE;

  M250:MA(C,250),COLORBROWN,LINETHICK2;

  ZT:=REF(C,1)*1.1-C《0.01 AND H=C;{涨停}

  DT:=IF((REF(C,1)-C)*100/REF(C,1)》=(10-0.01*100/REF(C,1)) AND L=C,1,0);{跌停};

  BA:STICKLINE(ZT,OPEN,CLOSE,0.1,0),COLORMAGENTA;

  BC:STICKLINE(DT,OPEN,CLOSE,0.1,0),COLORLIGREEN;

  DA:=YEAR AND MONTH AND DAY;

  AAA:=STRCAT(CON2STR(YEAR,0),‘年’);

  AAB:=STRCAT(CON2STR(MONTH,0),‘月’);

  AA33:=STRCAT(CON2STR(DAY,0),‘日’);

  AA4:=STRCAT(‘【’,IF(WEEKDAY=1,‘一’,IF(WEEKDAY=2,‘二’,IF(WEEKDAY=3,‘三’,IF(WEEKDAY=4,‘四’,IF(WEEKDAY=5,‘五’,IF(WEEKDAY=6,‘六’,‘日’)))))));

  AA:=STRCAT(STRCAT(STRCAT(AAA,AAB),STRCAT(AA33,AA4)),‘】’);

  SA:DRAWTEXT_FIX(DA,0,1,0,AA),COLORGREEN;