通达信超跌薛斯底主图+选股指标公式


  超跌薛斯底: 1、一波加速度下跌后出现止跌、反转K线。 2、系统连续出现薛斯底并且两天提示买进。 3、底部连续的地量。 4、在19.1%以下连续出现信号。 5、筹码主峰不在下移。 6、股价突破趋势线或者站上持股线买入。

  持股线:(EMA(CLOSE,6)+EMA(CLOSE,7)+EMA(CLOSE,8)+EMA(CLOSE,9))/4;

  NOTEXT001:IF(持股线》=REF(持股线,1),持股线,DRAWNULL),LINETHICK2 COLORRED;

  NOTEXT002:IF(持股线《REF(持股线,1),持股线,DRAWNULL),LINETHICK2,COLORGREEN;

  VAR2:=CLOSE*VOL;

  VAR33:=EMA((EXPMA(VAR2,3)/EXPMA(VOL,3)+EXPMA(VAR2,6)/EXPMA(VOL,6)+EXPMA(VAR2,12)/EXPMA(VOL,12)+EXPMA(VAR2,30)/EXPMA(VOL,30))/4,13);

  SUP:=1.06*VAR33;

  SDN:=VAR33*0.94;

  VAR34:=EXPMA(CLOSE,9);

  LUP:=EXPMA(VAR34*1.14,5);

  LDN:=EXPMA(VAR34*0.86,5);

  XG:=CROSS(SUP,LUP) OR ((LUP/SUP)《1.01 AND (LUP-SUP)《=REF((LUP-SUP),1) AND LUP》SUP);

  DRAWICON(XG》0,LOW-0.2,43);

  DRAWTEXT(XG》0,LOW, ‘薛斯底’);

  DRAWTEXT_FIX(1,0.00,0.00,0,‘主题投资:’)COLOR0000FF;

  DRAWTEXT_FIX(1,0.07,0.00,0,EXTERNSTR(0,1))COLOR0000FF;

  DRAWTEXT_FIX(1,0.00,0.08,0,‘主营业务:’)COLORFF00FF;

  DRAWTEXT_FIX(1,0.07,0.08,0,EXTERNSTR(0,2))COLORFF00FF;

  流通市值:(FINANCE(40)/100000000),NODRAW,COLORRED;

  涨停:=IF(REF(C,1)*1.090-C《0.01 ,1,0);

  STICKLINE(涨停,OPEN,CLOSE,4,0),COLORRED;

  STICKLINE(涨停,OPEN,CLOSE,3,0),COLORRED;

  {DRAWTEXT(涨停,L-0.1,‘涨停’),COLORRED;}

  C3:=REF(C,1);

  跌停:=IF((C3-C)*100/C3》=(10-0.01*100/C3),1,0);

  STICKLINE(跌停,OPEN,CLOSE,4,0),COLORBLUE;

  STICKLINE(跌停,OPEN,CLOSE,3,0),COLORBLUE;

  {DRAWTEXT(跌停,H+0.3,‘跌停’),COLORBLUE;};

  {

  选股公式:

  VAR29:=CLOSE*VOL;

  VAR30:=EMA((EXPMA(VAR29,3)/EXPMA(VOL,3)+EXPMA(VAR29,6)/EXPMA(VOL,6)+EXPMA(VAR29,12)/EXPMA(VOL,12)+EXPMA(VAR29,24)/EXPMA(VOL,24))/4,13);

  SUP:=1.06*VAR30;

  SDN:=VAR30*0.94;

  VAR40:=EXPMA(CLOSE,9);

  LUP:=EXPMA(VAR40*1.14,5);

  LDN:=EXPMA(VAR40*0.86,5);

  XG:=CROSS(SUP,LUP) OR ((LUP/SUP)《1.01 AND (LUP-SUP)《=REF((LUP-SUP),1) AND LUP》SUP);

  选股:XG》0;

  }