通达信佛勒定乾坤主图指标公式


  MA4:MA(C,4);

  MA9:MA(C,9);

  MA29:MA(C,29);

  DIFF:=EMA(CLOSE,11)-EMA(CLOSE,25);

  DEA:=EMA(DIFF,8);

  MACD:=2*(DIFF-DEA);

  MACD1:=CROSS(DIFF,DEA) AND COUNT(MACD》0,1)=1;

  RSV:=(CLOSE-LLV(LOW,8))/(HHV(HIGH,8)-LLV(LOW,8))*100;

  K:=SMA(RSV,8,1);

  D:=SMA(K,8,1);

  J:=3*K-2*D;

  KDJ1:=CROSS(K,D) AND CROSS(J,D);

  均线:=CROSS(MA(C,4),MA(C,9));

  量线:=CROSS(MA(V,4),MA(V,9));

  SCC:=MACD1 AND KDJ1 AND 均线 AND 量线;

  SC1:=MACD1 AND KDJ1;

  SC2:=均线 AND 量线;

  SC3:=均线 AND MACD1;

  SC4:=量线 AND KDJ1;

  SC5:=均线 AND KDJ1;

  SC6:=MACD1 AND 量线;

  DRAWICON(SC1 OR SC2 OR SC3 OR SC4 OR SC5 OR SC6,L-0.20,9);{两个以上指标同时金叉显示9号图标}

  DRAWICON(SCC,L-0.20,3);{四个指标同时金叉显示3号图标,便于区别};

  JLCH1:=CLOSE》OPEN;

  JLCH2:=JLCH1&&CLOSE》MA(CLOSE,20)&&CLOSE》MA(CLOSE,40)&&CLOSE》MA(CLOSE,60);

  JLCH3:=JLCH2&&OPEN《MA(CLOSE,40)&&OPEN《MA(CLOSE,60);

  DRAWTEXT(JLCH3&&(CLOSE-OPEN)》0.0618*CLOSE,O,‘出水芙蓉’);

  BUY1:=LAST(CLOSE》MA(CLOSE,120),0,5);

  BUY2:=EXIST(CLOSE《MA(CLOSE,120),5);

  DRAWTEXT(CLOSE》MA(CLOSE,120)&&BUY1&&BUY2,L-0.1,‘蜻蜓点水’);

  STAR:=REF(CLOSE,2)/REF(OPEN,2)《0.95&&

  REF(OPEN,1)《REF(CLOSE,2)&&

  ABS(REF(OPEN,1)-REF(CLOSE,1))/REF(CLOSE,1)《0.03&&

  CLOSE/OPEN》1.05&&CLOSE》REF(CLOSE,2);

  DRAWTEXT(STAR,LOW,‘早晨之星’);

  A1:=ABS(CLOSE-OPEN)/OPEN《0.015;

  A2:=COUNT(A1,4)=4;

  A3:=REF(OPEN,4)《REF(CLOSE,4) AND

  REF(CLOSE,4)/REF(CLOSE,4+1)》1+7/100;

  DRAWTEXT(A2 AND A3,LOW,‘强势整理’);