通达信十合一选股指标公式


  VAR1:=LLV(LOW,21);

  VAR2:=HHV(HIGH,21);

  AK1:=EMA((((CLOSE - VAR1) / (VAR2 - VAR1)) * 100),5);

  AK:=EMA((((CLOSE - VAR1) / (VAR2 - VAR1)) * 50),13);

  DD:=EMA(((0.667 * REF(AK1,1)) + (0.333 * AK1)),2);

  VAR3:=LLV(LOW,55);

  VAR4:=HHV(HIGH,34);

  VAR5:=EMA((((CLOSE - VAR3) / (VAR4 - VAR3)) * 100),3);

  VAR6:=((AK + VAR5) / 2);

  VAR7:=EMA(((0.667 * REF(VAR5,1)) + (0.333 * AK1)),2);

  VAR8:=EMA(VAR6,5);

  BB:=EMA(((0.667 * REF(VAR8,1)) + (0.333 * VAR8)),2);

  AB:=CROSS(AK1,AK);

  BB1:=(CROSS(AK1,BB) AND (BB 《 30));

  CD:=(BB1 * 0.6);

  MR:=(AB = 1) AND (CD = 0.6);

  DRAWICON(MR,1,18);

  DR:=100;ZRQ:=3;

  DJ:=REF(LLV(L,100),3);

  ZD:=REFDATE(DJ,DATE);

  XG:=L=ZD;

  DRAWICON(XG,2,13);

  VAR11:=CLOSE/REF(CLOSE,1)》=1.09 AND HIGH/CLOSE《1.005 AND MA(CLOSE,90)/CLOSE》=1.1;

  XG2:=VAR11 AND COUNT(VAR11,20)=1;

  DRAWICON(XG2,1.5,24);

  GJTJ1:=100*(C-LLV(L,5))/(HHV(C,5)-LLV(L,5));

  GJTJ2:=100*(C-LLV(L,10))/(HHV(C,10)-LLV(L,10));

  GJTJ3:=100*(C-LLV(L,20))/(HHV(C,20)-LLV(L,20));

  GJTJ4:=100*(C-LLV(L,30))/(HHV(C,30)-LLV(L,30));

  A:=BARSLAST(CROSS(50,GJTJ1))《3 AND BARSLAST(CROSS(GJTJ1,50))《3;

  B:=BARSLAST(CROSS(GJTJ4,GJTJ1))《2 AND GJTJ1》GJTJ4;

  A1:=BARSLAST(CROSS(30,GJTJ1))《2 AND BARSLAST(CROSS(GJTJ1,50))《2;

  B1:=BARSLAST(CROSS(GJTJ4,GJTJ1))《2 AND GJTJ1》GJTJ4;

  E:=GJTJ1》60 AND GJTJ4》70;

  XG3:=A1 AND B1 AND E;

  DRAWICON(XG3,2.5,26);

  XG1:=A AND B;

  DRAWICON(XG1,3,25);

  VAR12:=C/MA(C,20)*100《80;VAR22:=C/MA(C,40)*100《78;

  VAR32:=C/MA(C,60)*100《72;

  VAR42:=H》L*1.051;

  VAR52:=VAR42 AND COUNT(VAR42,5)》1;

  XG4:=VAR52 AND (VAR12 OR VAR22 OR VAR32);

  DRAWICON(XG4,3.5,27);

  VAR23:=(CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100;

  VAR33:=(CLOSE-MA(CLOSE,12))/MA(CLOSE,12)*100;

  VAR43:=(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100;

  VAR53:=(VAR23+2*VAR33+3*VAR43)/7;

  VAR63:=MA(VAR53,1);

  消失后买:= IF(VAR63《-8,20,0);

  DRAWICON( 消失后买,4,28);

  XJYY:=(CLOSE-MA(CLOSE,42))/MA(CLOSE,42)*100;

  XG5:=CROSS(-28,XJYY) ;

  DRAWICON( XG5,4.5,29);

  SS1:=(LOW+HIGH+CLOSE*2)/4;

  SS2:= MA(SS1,4);

  SS3:=HHV(SS2,10);

  SS4:=MA(SS3,3);

  SS5:=1.25*SS4-0.25*SS3;

  XKKJ:=IF(SS5》SS3,SS3,SS5);

  FF1:=LLV(SS2,10);

  FF2:=MA(FF1,3);

  FF3:=1.25*FF2-0.25*FF1;

  DKKJ:=IF(FF3《FF1,FF1,FF3);

  MA13:=MA(C,13);

  ZDHM:=CROSS(C,DKKJ) AND CROSS(C,MA13) AND CROSS(C,XKKJ);

  ZHM:=CROSS(C,MA13) AND CROSS(C,XKKJ);

  XG6:=ZDHM OR ZHM;

  DRAWICON( XG6,5,30);

  买入必涨:=((((CLOSE / REF(CLOSE,1)) 》= 1.07) AND ((HIGH / CLOSE) 《 1.005)) AND ((MA (CLOSE,90) / CLOSE) 》1.48));

  DRAWICON(买入必涨 ,5.5,31);