通达信最牛最全主图指标公式


  MA5:MA(C,5);

  MA6:=MA(C,6);

  MA10:MA(C,10);

  MA20:MA(C,20);A2:=REF(MA20,1);J1:=(MA20-A2)/A2*100;MJ1:=MA(J1,3);

  MA30:MA(C,30);

  MA60:MA(C,60);

  MA120:MA(C,120);

  乖离2:=(MA20-MA30)/MA30*100;

  VAR1:=IF(BETWEEN(乖离2,-2,5),2,0);

  MAX1:=MAX(MA20,MA30);

  MAX2:=MAX(MAX1,MA60);

  MIN11:=MIN(MA20,MA30);

  MIN2:=MIN(MIN11,MA60);

  K1:=(MAX2/MIN2-1)*100;{粘合度符合条件}

  VAR2:=IF(K1《=8,1,0);

  上火车轨:=MA20》MA30 AND MA20》REF(MA20,1) AND MA30》REF(MA30,1) AND MA20-MA30》REF((MA20-MA30),1) ;

  STICKLINE(上火车轨,MA20,MA30,0,0),COLORRED;

  神枪手:=DRAWTEXT(FILTER(上火车轨 AND “MACD.DIF”《0.15 AND “MACD.DIF”》REF(“MACD.DIF”,1) AND MA(V,60)》REF(MA(V,60),1) AND MA(V,5)》MA(V,10) AND J1》REF(J1,1) AND

  ( L《=MA20 AND C》MA20 OR (CROSS(MA5,MA20)) ),5),L*0.98,‘←神枪手’);

  神枪手选股:=FILTER(上火车轨 AND “MACD.DIF”《0.15 AND “MACD.DIF”》REF(“MACD.DIF”,1) AND MA(V,60)》REF(MA(V,60),1) AND MA(V,5)》MA(V,10) AND J1》REF(J1,1) AND

  ( L《=MA20 AND C》MA20 OR (CROSS(MA5,MA20)) ),5);{44.40%15240}

  短线暴张:DRAWTEXT(FILTER( (VAR1 OR VAR2) AND MA10》REF(MA10,1) AND COUNT(MA30》REF(MA30,1),3)=3 AND MA30》MA60 AND COUNT(CROSS(MA5,MA30),3) AND J1》MJ1 AND MA(V,5)》MA(V,60)

  AND MA(V,60)》REF(MA(V,60),1),5),MA60*0.99,‘短线暴张’),COLORRED;

  DRAWTEXT(CROSS(“KDJ.K”(5,2,3),“KDJ.D”(5,2,3)) AND “KDJ.D”(5,2,3)《30 AND J1》MJ1 AND MA60》REF(MA60,1) AND COUNT(J1《1,3)》=1 ,L*0.995,‘←买入’),COLORYELLOW;

  DRAWTEXT(CROSS(“KDJ.D”(5,2,3),“KDJ.K”(5,2,3)) AND “KDJ.D”(5,2,3)》65 AND J1《MJ1 AND COUNT(J1》1,3)》=1,H*1.005,‘←卖出’),COLORGREEN;

  DRAWTEXT(CROSS(“KDJ.D”(18,9,6),“KDJ.K”(18,9,6)) AND “KDJ.D”(18,9,6)》60 AND “KDJ.J”(45,15,15)》90,H*1.03,‘←顶’),COLORRED;

  DRAWTEXT(CROSS(MA5,MA6) AND “KDJ.K”(5,3,3)》=50 AND “KDJ.J”(5,3,3)《31 ,L*0.92,‘←再买’),COLORMAGENTA;

  XL1:=((LLV(LOW,3) = LLV(LOW,60)) AND ((CLOSE / REF(CLOSE,1)) 》= 1.04));

  XL2:=(((CLOSE - EMA(CLOSE,21)) / EMA(CLOSE,21)) * 100);

  XL3:=CROSS(XL2,(0 - 20));

  DRAWTEXT(FILTER(((XL1 》 0) AND LOW),5),(LOW - 0.4),‘●买点’);

  DRAWTEXT((XL3 》 0),(LOW - 0.2),‘●绝对底部’);

  X6:=REF(CLOSE,1);

  X7:=((SMA(MAX((CLOSE - X6),0),7,1) / SMA(ABS((CLOSE - X6)),7,1)) * 100);

  X8:=CROSS(79,X7);

  X9:=FILTER(X8,4);

  DRAWTEXT(X9,(HIGH * 1.02),‘●出货’),COLOR9000F5;

  STICKLINE(C》1.098*REF(C,1),C,O,0,0),COLOR