同花顺料涨入神波段涨跌源码免费指标公式


  同花顺料涨入神波段涨跌源码免费指标公式

  出现买入箭头时并非最佳买点,指标图形在底部构成三角形就已经可以买入了。

  LC:=REF(CLOSE,1);

  RSI5:=((SMA(MAX((CLOSE - LC),0),5,1) / SMA(ABS((CLOSE - LC)),5,1)) * 100);

  TR1:=SUM(MAX(MAX((HIGH - LOW),ABS((HIGH - REF(CLOSE,1)))),ABS((LOW - REF(CLOSE,1)))),10);

  HD:=(HIGH - REF(HIGH,1));

  LD:=(REF(LOW,1) - LOW);

  DMP:=SUM(IF(((HD 》 0) AND (HD 》 LD)),HD,0),10);

  DMM:=SUM(IF(((LD 》 0) AND (LD 》 HD)),LD,0),10);

  PDI:=((DMP * 100) / TR1);

  MDI:=((DMM * 100) / TR1);

  ADX:=MA(((ABS((MDI - PDI)) / (MDI + PDI)) * 100),5);

  AV:=(RSI5 + ADX);

  DXR:=(((ADX + REF(ADX,5)) / 2) + RSI5);

  WR10:=((100 * (HHV(HIGH,10) - CLOSE)) / (HHV(HIGH,10) - LLV(LOW,10)));

  NEWVOL:=(RSI5 - WR10);

  最佳买入:=(AV + NEWVOL);

  买入选股:IF(CROSS(最佳买入,0),4,0),STICK,COLOR00FFFF,LINETHICK2;

  VARA1:=SMA(买入选股,3,1);

  VARA2:=SMA(VARA1,3,1),COLOR0000FF;

  VARA3:=SMA(VARA2,3,1),COLOR00FFFF;

  建仓买点:IF(CROSS(VARA2,VARA3) AND (VARA2《40),5,0* 10000),COLOR0000FF,LINETHICK1;

  STICKLINE(建仓买点,0,1.5,6,0),COLORFF80FF;

  STICKLINE(建仓买点,0.5,2.8,2,0),COLOR3000FF;

  RSV:=(((CLOSE - LLV(LOW,9)) / (HHV(HIGH,9) - LLV(LOW,9))) * 50);

  K:=SMA(RSV,3,1);

  D:=SMA(K,3,1);

  J:=3*K-2*D;

  X:=LLV(J,2)=LLV(J,8);

  最佳买入时机: IF(CROSS(J,3),1,0),STICK,COLORFFFF00;

  STICKLINE(最佳买入时机,0,1,3,0),COLOR009999;

  STICKLINE(最佳买入时机,0,1,2,0),COLOR00DDDD;

  STICKLINE(最佳买入时机,0,1,1,0),COLOR00FFFF;

  机构建仓: IF(最佳买入《5,-0.5,0),STICK,COLOR00FF00,LINETHICK1;

  机构建仓日:STICKLINE(机构建仓,0,-1,4,1),COLOR00FF00,LINETHICK5;

  趋势:3*SMA((CLOSE-LLV(LOW,38))/(HHV(HIGH,38)-LLV(LOW,38))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1),LINETHICK2,COLORFF99FF,NODRAW;

  备钱: IF(趋势《=20,-0.8,0),COLORD0D0D0,STICK,LINETHICK3;

  快买: IF(趋势《=10,1,0),COLORFF38FF,STICK,LINETHICK3;

  BIAS1:=(C-MA(C,6))/MA(C,6)*100,COLORFFDDCC;

  BIAS2:(C-MA(C,13))/MA(C,13)*100,COLORFFFFFF,LINETHICK1;

  BIAS3:=(C-MA(C,26))/MA(C,26)*100,COLORFFFFFF,LINETHICK1;

  乖离:(BIAS1+2*BIAS2+3*BIAS3)/6,COLOR00FFFF;

  乖离超限:MA(乖离,3),COLORFF80FF;

  STICKLINE(CROSS(乖离,乖离超限) AND 乖离超限《-9,-4,0,1,1),COLORFFFFFF;

  STICKLINE(CROSS(乖离超限,乖离) AND 乖离》10,6,0,3,0),COLORFF88FF;

  DRAWBAND(MA(乖离,1),RGB(240,120,40),MA(乖离超限,1),RGB(256,200,20));

  警跌:IF(BIAS2《REF(BIAS2,1),BIAS2,DRAWNULL),COLORFF6128,LINETHICK3;

  回升:IF(BIAS2》REF(BIAS2,1),BIAS2,DRAWNULL),COLOR00FFFF,LINETHICK3;

  R:SMA(MAX(CLOSE- REF(C,1),0),6,1)/SMA(ABS(CLOSE- REF(C,1)),6,1)*100,COLORFFCCFF,NODRAW;

  R2:SMA(MAX(CLOSE- REF(C,1),0),13,1)/SMA(ABS(CLOSE- REF(C,1)),13,1)*100,COLOR00CCFF,NODRAW;

  STICKLINE(CROSS(R2,R) AND R2》78,2,0,3,-1),COLOR30FFFF;

  CC:=(C-REF(C,1))/REF(C,1)*100》1.2;

  DD:=L《MA(C,5)*0.921;

  EE:=V《MA(V,5)*1.5;

  老鼠仓:=(L《(AMOUNT/V)*0.9) AND CC AND DD AND EE,LINETHICK0,COLOR0099FF;

  DRAWTEXT(老鼠仓,-5,‘老鼠仓’),COLORFFFFFF;

  STICKLINE(CROSS(乖离,BIAS1) AND BIAS2》15,乖离,0,1,0),COLOR3300FF;

  DRAWICON(CROSS(乖离,BIAS1*0.382),-1,1),colorgreen;