同花顺江恩三线操盘主图指标公式


  说明:根据短、中、长三线控制仓位。三线之上90%仓位、两线之上60%、一线之上30%、三线之下空仓。

  工作线17:EMA(CLOSE,17),coloryellow;

  中期线50:EMA(CLOSE,50),linethick2;

  长期线453:EMA(CLOSE,453),colorred,linethick2;

  DIFF:=( EMA(CLOSE,7) - EMA(CLOSE,19));

  DEA:=EMA(DIFF,9);

  MACD:=0.90*(DIFF-DEA);

  tj:=(diff》=dea);

  tj1:=(diff》=0);

  STICKLINE(tj,H,L,0,0),coloryellow;

  STICKLINE(tj,O,C,8,0),coloryellow;

  STICKLINE(tj1 AND tj,H,L,0,0),colorred;

  STICKLINE(tj1 AND tj,O,C,8,0),colorred;

  STICKLINE(diff《dea,H,L,0,1),colorffcc00;

  STICKLINE(diff《dea,O,C,8,1),colorffcc00;

  Var1:=(CLOSE*2+HIGH+LOW)/4;

  SK:= EMA(Var1,13)-EMA(Var1,73);

  SD:= EMA(SK,2);

  DRAWTEXT((CROSS(sk,sd) AND sk《-0.04 AND (C-REF(C,1))/REF(C,1)》=0.03) OR (CROSS(sk,sd) AND sk《=-0.14 )

  OR (CROSS(sk,sd) AND sk《=0.05 AND (V/MA(V,5)》2 OR C/REF(C,1)》0.035)) ,L*0.99,‘短线’),colorgreen;

  STICKLINE((CROSS(sk,sd) AND sk《-0.04 AND (C-REF(C,1))/REF(C,1)》=0.03) OR (CROSS(sk,sd) AND sk《=-0.14 )

  OR (CROSS(sk,sd) AND sk《=0.05 AND (V/MA(V,5)》2 OR C/REF(C,1)》0.035)),H,L,0.5,0),colorred;

  STICKLINE((CROSS(sk,sd) AND sk《-0.04 AND (C-REF(C,1))/REF(C,1)》=0.03) OR (CROSS(sk,sd) AND sk《=-0.14 )

  OR (CROSS(sk,sd) AND sk《=0.05 AND (V/MA(V,5)》2 OR C/REF(C,1)》0.035)),O,C,10,1),linethick3,colorred;