文华财经公式 趋势顶底


趋势顶底

趋势顶底 文华用


FILLRGN(1,20,80,COLORLIGHTGREY);
FILLRGN(1,90,100,COLORLIGHTRED);
FILLRGN(1,79,90,COLORLIGHTGREEN);
FILLRGN(1,10,20,COLORLIGHTBLUE);
FILLRGN(1, 0,10,COLORCYAN);

A:=MA(-100*(HHV(HIGH,N)-CLOSE)/(HHV(HIGH,N)-LLV(LOW,N)),19),COLORRED;
B:=-100*(HHV(HIGH,14)-CLOSE)/(HHV(HIGH,14)-LLV(LOW,14));
D:=EMA(-100*(HHV(HIGH,34)-CLOSE)/(HHV(HIGH,34)-LLV(LOW,34)),4);

CHANG:A+100,COLORRED;
DUAN:B+100,COLORBLUE;
ZHONG:D+100,COLORYELLOW;
JIANDING:(REF(ZHONG,1)>85 AND REF(DUAN,1)>85 AND REF(CHANG,1)>65) AND CROSS(CHANG,DUAN) ;
DINGBUQUYU:(ZHONG80) AND (REF(DUAN,1)>95 OR REF(DUAN,2)>95 ) AND CHANG>60 AND DUAN<83.5 AND DUANDINGBU:=FILTER(DINGBUQUYU,4);
DIBUQUYU:(CHANG<12 AND ZHONG<8 AND (DUAN<7.2 OR REF(DUAN,1)<5) AND (ZHONG>REF(ZHONG,1) OR DUAN>REF(DUAN,1))) OR (CHANG<8 AND ZHONG<7 AND DUAN<15 and="" duan="">REF(DUAN,1)) OR (CHANG<10 AND ZHONG<7 AND DUAN<1) ;
STICKLINE( JIANDING||DINGBU,99,103,COLORRED,1 );
STICKLINE( DIBUQUYU,-4,0,COLORGREEN,0 );
DIWEIJINCHA:CHANG<15 AND REF(CHANG,1)<15 AND ZHONG<18 and="" duan="">REF(DUAN,1) AND CROSS(DUAN,CHANG) AND DUAN>ZHONG AND (REF(DUAN,1)<5 OR REF(DUAN,2)<5 ) AND (ZHONG>=CHANG OR REF( DUAN,1)<1 );
STICKLINE( DIWEIJINCHA,0,5,COLORRED,0 );