不同止损策略编写方法[文华财经公式]


咨询内容:
例如:

以开盘后的第一根K线作为标准,

1、突破其最高点BPK,第一次开多盈利50点止盈

2、跌破其最低点SPK,第一次开空盈利90点止盈

3、跌破最低点后没有达到止盈标准,价格有回到第一根K线的高点之上,再度BPK,第二次开多止盈为盈利100点。

4、之后多单未能止盈,又回到低点之下,这样就空单盈利120点止盈。

5、如空单没有止盈,又回到其高点上,用开多盈利130点止盈。

6、价格又下了开空后150点止盈。

橡胶、1分钟周期上,

文华技术人员:
N:=BARSLAST(DATE<>REF(DATE,1));
HH:=VALUEWHEN(DATE<>REF(DATE,1),H);
LL:=VALUEWHEN(DATE<>REF(DATE,1),L);
N>=1&&C>HH,BPK;
N>=1&&C<LL,SPK;
COUNT(BARSBK=1,N)=1&&C>BKPRICE+50,SP;
COUNT(BARSSK=1,N)=1&&C<SKPRICE-90,BP;
COUNT(BARSBK=1,N)=2&&C>BKPRICE+100,SP;
COUNT(BARSSK=1,N)=2&&C<SKPRICE-120,BP;
COUNT(BARSBK=1,N)=3&&C>BKPRICE+130,SP;
COUNT(BARSSK=1,N)=3&&C<SKPRICE-150,BP;
AUTOFILTER;

仅供参考!