[文华财经公式]RSI模型 我想请问一下如何只让当天第一个信号有效


咨询内容:
比如,1分钟周期下,以当天第一次rsi>80的那根K线为参考,向上突破开多,向下突破开空。但只有当天的第一次rsi>80那根K线有效。而且多空在当天各只做一把。

请问怎么实现。主要是限制当天只有第一突破开仓,以后再经过这个轴的全无效

文华技术人员:
LC := REF(CLOSE,1);//前一周期收盘价
RSI:SMA(MAX(CLOSE-LC,0),7,1)/SMA(ABS(CLOSE-LC),7,1)*100;//当根K线收盘价与前一周期收盘价做差,在该差值与0之间取最大值,做N1周期移动平均。收盘价与前一周期收盘价做差值,取该差值的N1周期移动平均值,两平均值之间做比值。
N:=BARSLAST(DATE<>REF(DATE,1))+1;
A:=RSI>80&&COUNT(RSI>80,N)=1;
NN:=BARSLAST(A);
CC:=VALUEWHEN(A,C);
C>CC&&NN<N&&COUNT(BARSBK=1,N)=0,BPK;
C<CC&&NN<N&&COUNT(BARSSK=1,N)=0,SPK;
AUTOFILTER;

仅供参考!