博弈大师指标改成文华财经


咨询内容:以下为博易指标源码 麻烦改编成 文华财经
LC:=REF(CLOSE,1);
RSI:=SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100;
VARB:=SMA(MAX(CLOSE-LC,0),7,1)/SMA(ABS(CLOSE-LC),7,1)*100;
VARC:=SMA(MAX(CLOSE-LC,0),13,1)/SMA(ABS(CLOSE-LC),13,1)*100;
VARD:=BARSCOUNT(CLOSE);
底部初显:(VARB< 20 AND VARC< 25 AND VARD> 50)*30,LINETHICK2, COLORFF9933;
LK:EMA( (CLOSE-MA(CLOSE,7))/MA(CLOSE,7)*480,2),LINETHICK3 ,COLORRED;
LD:EMA( (CLOSE-MA(CLOSE,10))/MA(CLOSE,10)*480,10),LINETHICK3 ,COLORGREEN;
DRAWTEXT(CROSS(LK,LD) AND LK<-10,-20,'要反弹'),COLORYELLOW;
DRAWICON(CROSS(LK,LD) AND LK<-10 AND LD>REF(LD,1)OR CROSS(LK,LD) AND LD<-35 ,-15,1);
MAV:=(2*C+H+L)/4;
VAR1:=LLV(LOW,4);
VAR2:=HHV(HIGH,7);
SK:EMA((MAV-VAR1)/(VAR2-VAR1)*100,13);
SD:EMA(0.667*REF(SK,1)+0.333*SK,2);
DRAWTEXT(CROSS(SK,SD),SK,'多 '),COLORRED;
DRAWTEXT(CROSS(SD,SK),SD,'空 '),COLORGREEN;

DIR:=ABS(CLOSE-REF(CLOSE,10));
VIR:=SUM(ABS(CLOSE-REF(CLOSE,1)),10);
ER:=DIR/VIR;
CS:=ER*(2/3-2/31)+2/31;
CQ:=CS*CS;
AMA:DMA(CLOSE,CQ),COLORGREEN,LINETHICK0;

持股:(CLOSE>AMA),COLORGREEN;
持币:(CLOSE<AMA),COLORRED;

STICKLINE(CLOSE<AMA,0,2,8,0),COLORRED;
STICKLINE(CLOSE>AMA,0,2,8,0),COLORGREEN;

{个股15分钟}

A15:=MAX(MA(C,5),MA(C,10));
B15:=MIN(MA(C,5),MA(C,10));
STICKLINE(C>A15,-2,-1,4,0),COLORGREEN;
STICKLINE(C<B15,-2,-1,4,0),COLORRED;
STICKLINE(A15>=C AND C>=B15,-2,-1,4,0),COLORYELLOW;
{个股30分钟}
A30:=MAX(MA(C,10),MA(C,20));
B30:=MIN(MA(C,10),MA(C,20));
STICKLINE(C>A30,-4,-3,4,0),COLORGREEN;
STICKLINE(C<B30,-4,-3,4,0),COLORRED;
STICKLINE(A30>=C AND C>=B30,-4,-3,4,0),COLORYELLOW;

{个股60分钟}
A60:=MAX(MA(C,20),MA(C,28));
B60:=MIN(MA(C,20),MA(C,28));
STICKLINE(C>A60,-6,-5,4,0),COLORGREEN;
STICKLINE(C<B60,-6,-5,4,0),COLORRED;
STICKLINE(A60>=C AND C>=B60,-6,-5,4,0),COLORYELLOW;

客服人员回复:
为您改写如下:

A15:=MAX(MA(C,5),MA(C,10));
B15:=MIN(MA(C,5),MA(C,10));
STICKLINE(C>A15,-2,-1,COLORGREEN,0);
STICKLINE(C<B15,-2,-1,COLORRED,0);
STICKLINE(A15>=C AND C>=B15,-2,-1,COLORYELLOW,0);

A30:=MAX(MA(C,10),MA(C,20));
B30:=MIN(MA(C,10),MA(C,20));
STICKLINE(C>A30,-4,-3,COLORGREEN,0);
STICKLINE(C<B30,-4,-3,COLORRED,0);
STICKLINE(A30>=C AND C>=B30,-4,-3,COLORYELLOW,0);

A60:=MAX(MA(C,20),MA(C,28));
B60:=MIN(MA(C,20),MA(C,28));
STICKLINE(C>A60,-6,-5,COLORGREEN,0);
STICKLINE(C<B60,-6,-5,COLORRED,0);
STICKLINE(A60>=C AND C>=B60,-6,-5,COLORYELLOW,0);

LC:=REF(CLOSE,1);
RSI:=SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100;
VARB:=SMA(MAX(CLOSE-LC,0),7,1)/SMA(ABS(CLOSE-LC),7,1)*100;
VARC:=SMA(MAX(CLOSE-LC,0),13,1)/SMA(ABS(CLOSE-LC),13,1)*100;
VARD:=BARSCOUNT(CLOSE);
DBCX:(VARB< 20 AND VARC< 25 AND VARD> 50)*30,COLORBLUE;
LK:EMA((CLOSE-MA(CLOSE,7))/MA(CLOSE,7)*480,2),COLORRED;
LD:EMA((CLOSE-MA(CLOSE,10))/MA(CLOSE,10)*480,10),COLORGREEN;
DRAWTEXT(CROSS(LK,LD) AND LK<-10,-20,'YFT'),COLORYELLOW;
DRAWICON(CROSS(LK,LD)&&LK<-10 &&LD>REF(LD,1)||CROSS(LK,LD)&&LD<-35 ,-15,'ICO1');
MAV:=(2*C+H+L)/4;
VAR1:=LLV(LOW,4);
VAR2:=HHV(HIGH,7);
SKK:EMA((MAV-VAR1)/(VAR2-VAR1)*100,13);
SD:EMA(0.667*REF(SK,1)+0.333*SKK,2);
DRAWTEXT(CROSS(SK,SD),SK,'多');
DRAWTEXT(CROSS(SD,SK),SD,'空');