文华指标---跨周期调用模型编写


跨周期调用

咨询内容:
问题一30分钟k线走势中,20均线走平开始上拐,kdj种的j值小于10;

5分钟中k线中j值小于5发出买入信号如何表示?

问题二':日k线下,10天内kdj种的j值出现过一次小于-2的,而30分钟kdj已经出现kdj背离,金叉时在k线最低价处在显示向上的红箭头,谢谢!

赢顺技术人员:
我的软件版本是8.0.017

赢顺客服:
可使用跨周期模型实现,关于跨周期模型在论坛中已多次讨论,您可通过论坛搜索“跨周”查找相关帖子学习;

网友回复:

进去老是卡出来了,郁闷撒,搜索的都不同!

网友回复:
1、第一个问题:

首先建立AA模型

RSV:=(CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100;
K:SMA(RSV,M1,1);
D:SMA(K,M2,1);
J:3*K-2*D;
MA20:MA(C,20);

再建立一个模型BB

#IMPORT[,MIN30,AA] AS VAR
MA20:VAR.MA20;
K30:VAR.K;
J30:VAR.J;
RSV:=(CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100;
K:SMA(RSV,M1,1);
D:SMA(K,M2,1);
J:3*K-2*D;
J<5&&MA20>REF(MA20,1)&&J30<10,BK;

2、第二个问题:

首先建立模型CC

RSV:=(CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100;
K:SMA(RSV,M1,1);
D:SMA(K,M2,1);
J:3*K-2*D;
AA:COUNT(J<-2,10)=1;

再建立模型DD

#IMPORT[,DAY,DD] AS VAR1
ADAY:VAR1.AA;
#IMPORT[,MIN30,DD] AS VAR2
MA20:VAR2.MA20;
K30:VAR2.K;
J30:VAR2.J;
D30:VAR2.D;
ADAY=1&&CROSS(K30,D30),BK;

仅供参考。