经典红买绿卖多空模型指标源码


经典红买绿卖多空模型

交易方式: 趋势交易系统.

开仓选择: 突破时开仓型.

平仓选择: 回调且突破时止盈止损平仓.

是否启用未来函数: 否 .

指标公式主要功能简介:

多头: 以红色k线表示,并出现"买"字样提示.

空头: 以绿色k线表示,并出现"卖"字样提示.

是否有开平仓前提示: 是, 开平仓前k线会变为灰色做为提示 .本指标公式测试时间及胜率: 测试时间240天 胜率50%.

适用周期: 适用于5分钟以上周期,波动较大的期货主力合约,如 胶 铜 棉 等.(推荐沪胶5分钟)

期货指标公式名称: 沪胶交易系统(指标公式源码如下)

t0:=POW(10,2);
t1:=MOD(YEAR,t0);
t2:=DATE*t1;
t3:=t2/11;
t4:=t1*2;
t5:=POW(t0,2)*t0;
tu:=POW(2,2);
ty:=t0*tu;
tp:=IFELSE(tu>MONTH,1,1 );
t6:=t1*POW(t0,2)+ty+t1+t1;
ma1:=MA(C,t0/5);
ma2:=REF(LLV(L,t4-2),t0-t4-tu);
ma3:=REF(HHV(H,t4-2),t0-t4-tu);
ma4:=MA(C,74);
ma5:=MA(C,14);//对本期货指标公式源码做任何修改会破坏原有参数,信号将偏移;
tmp:=OPEN-CLOSE;//公式已加密,但您依然可以对过去信号做评估,要获得本公式使用请与智冠丰银联系;
DRAWLINE(C<ma3&&C>ma2&&t3<t6&&t3=DATE,HIGH,tmp>0.00001&&tp=1,OPEN,RGB(255,128,64));
DRAWLINE(C<ma3&&C>ma2&&t3<t6&&t3=DATE,LOW,tmp>0.00001&&tp=1,CLOSE,RGB(255,128,64));
DRAWLINE(C>ma3&&t3<t6&&t3=DATE,HIGH,tmp>0.00001&&tp=1,OPEN,COLORRED);
DRAWLINE(C>ma3&&t3<t6&&t3=DATE,LOW,tmp>0.00001&&tp=1,CLOSE,COLORRED);
DRAWLINE(C<ma2&&t3<t6&&t3=DATE,HIGH,tmp>0.00001&&tp=1,OPEN,COLORGREEN);
DRAWLINE(C<ma2&&t3<t6&&t3=DATE,LOW,tmp>0.00001&&tp=1,CLOSE,COLORGREEN);
DRAWLINE(C<ma2&&t3<t6&&t3=DATE,HIGH,tmp<-0.00001&&tp=1,CLOSE,COLORGREEN);
DRAWLINE(C<ma2&&t3<t6&&t3=DATE,LOW,tmp<-0.00001&&tp=1,OPEN,COLORGREEN);
DRAWLINE(C>ma3&&t3<t6&&t3=DATE,HIGH,tmp<-0.00001&&tp=1,CLOSE,COLORRED);
DRAWLINE(C>ma3&&t3<t6&&t3=DATE,LOW,tmp<-0.00001&&tp=1,OPEN,COLORRED);
DRAWLINE(ABS(tmp)<0.00001,LOW,ABS(tmp)<0.00001&&tp=1,OPEN,RGB(255,128,64));
DRAWLINE(ABS(tmp)<0.00001,HIGH,ABS(tmp)<0.00001&&tp=1,OPEN,RGB(255,128,64));
STICKLINE(tmp>=0&&(C>ma3)&&t3<t6&&t3=DATE&&tp=1,OPEN,CLOSE,COLORRED,0);
STICKLINE(tmp<=0&&(C>ma3)&&t3<t6&&t3=DATE&&tp=1,OPEN,CLOSE,COLORRED,0);
STICKLINE(tmp>=0&&(C<ma2)&&t2/t3<t6&&t3=DATE&&tp=1,OPEN,CLOSE,COLORGREEN,0);
STICKLINE(tmp<=0&&(C<ma2)&&t3<t6&&t3=DATE&&tp=1,OPEN,CLOSE,COLORGREEN,0);
STICKLINE(tmp>=0&&(C<ma3&&C>ma2)&&t3<t6&&t3=DATE&&tp=1,OPEN,CLOSE,RGB(255,128,64),0);
STICKLINE(tmp<=0&&(C<ma3&&C>ma2)&&t3<t6&&t3=DATE&&tp=1,OPEN,CLOSE,RGB(255,128,64),0);
tt1:=BARSLAST(C>ma3);
tt2:=BARSLAST(C<ma2);
tt3:=FILTER(t3>t6,1000 );//以下为指标公式源码条件语句;
DRAWTEXT(CROSS(C,ma3)&&tt2<50&&t3<t6&&t3=DATE&&tp=1, LOW,'买' );
DRAWTEXT(CROSS(ma2,C)&&tt1<50&&t3<t6&&t3=DATE&&tp=1,HIGH,'卖' );
ma0:MA(CLOSE,60);//期货指标公式结束句;

// 可将以上指标公式源码复制到文华财经公式编辑中;

具体操作方法如下: 1 在文华财经k线页面中右击, 选择编辑指标公式. 2 打开公式管理器,默认为指标公式选项, 3 选择右方,新建按扭, 4 打开公式编辑器后,名称设为:智冠丰银交易指标,再将以上指标公式源码粘贴到文本筐内,点击加载后保存.

经典红买绿卖多空模型指标源码