橡胶日内交易模型源码


具体源码:

// 参数名称 最小值 最大值 默认值
// M 3.0 10.0 6.0
// N 3.0 10.0 4.0
//此系统为日内5分钟K线操作,适用橡胶合约
X:=REF(C-O,2);//参数2为实盘操作的数值,发信号立即交易
Y:=VALUEWHEN(DATE<>REF(DATE,1),REF(SETTLE,1));//取出当日开盘后的均价
XL:MA(X/Y,5);//定义变化斜率
BB:=REF(O,BARSBK+1);
SS:=REF(O,BARSSK+1);
TMP1:=(BB/L>=1.013);//SP,多单止损条件
TMP2:=(H/SS>=1.013);//BP,空单止损条件
ZDT:=ABS(H/Y-1)>0.0596||ABS(L/Y-1)>0.0596;//涨跌停
NZDT:=ABS(REF(C,1)/Y-1)<0.055&&ABS(REF(C,2)/Y-1)<0.055&&ABS(REF(C,3)/Y-1)<0.055;//涨跌幅大于5.5%不开仓
TIME>=0910 && TIME<1445 && NZDT && XL>=0.0001*M,BK;
TIME>=0910 && TIME<1445 && NZDT && XL<=-0.0001*M,SK;
TIME>=1453 || ZDT || TMP1 || XL<=-0.0001*N,SP;
TIME>=1453 || ZDT || TMP2 || XL>=0.0001*N,BP;
AUTOFILTER;