文华指标公式--量仓指标


量仓指标

(建议在3分钟图中使用)

NN:=BARSLAST(DATE<>REF(DATE,1))+1;
KH:=HHV(NN,300);

VERTLINE(DATE<>REFX(DATE,1)&&ISLASTBAR<>1&&KH<>1,COLORBLUE);

QQ:=OPI-REF(OPI,1);

K1:=IF(CLOSE>OPEN&&QQ>=0,QQ,0);
KK1:=IF(CLOSE<OPEN&&QQ<0,QQ,0);
KKK1:=IF(CLOSE=OPEN,QQ*0.5,0);
K2:=IF(CLOSE<OPEN&&QQ>=0,QQ,0);
KK2:=IF(CLOSE>OPEN&&QQ<0,QQ,0);
DO:=SUM(K1,NN)+SUM(KK1,NN)+SUM(KKK1,NN);
KO:=SUM(K2,NN)+SUM(KK2,NN)+SUM(KKK1,NN);
N4:=IF(NN<=4,NN,4);
VK1:=IF(CLOSE>=OPEN,VOL,0);
VK2:=IF(CLOSE<=OPEN,VOL,0);
VDO:=SUM(VK1,N4);
VKO:=SUM(VK2,N4);
VDK:=VDO-VKO;
STICKLINE(VDK>=0,VDK,0,COLORRED,0);
STICKLINE(VDK<=0,VDK,0,COLORCYAN,0);
CC:=SUM(QQ,NN);
DRAWNUMBER(ISLASTBAR&&CC>0,0,CC,0,COLORMAGENTA);
DRAWNUMBER(ISLASTBAR&&CC<0,0,CC,0,COLORBLUE);
POLYLINE(CLOSE>0,DO,COLORRED);
POLYLINE(CLOSE>0,KO,COLORGREEN);
W:=MOD(NN,5);
J:=BACKSET(ISLASTBAR,5);
DRAWNUMBER(ISLASTBAR,DO,DO,0,COLORYELLOW);
DRAWNUMBER(ISLASTBAR,KO,KO,0,COLORGREEN);
DRAWNUMBER(W=0&&J=0,DO,DO,0,COLORYELLOW);
DRAWNUMBER(W=0&&J=0,KO,KO,0,COLORGREEN);