文华指标公式--狮子趋势


狮子趋势

QS0:=((CLOSE - LLV(LOW,120)) / (HHV(HIGH,120) - LLV(LOW,120)));
QS1:=((QS0 / 1) * EMA(CLOSE,20));
QS:=SMA(QS1,3,1);
QD0:=((CLOSE - LLV(LOW,119)) / (HHV(HIGH,119) - LLV(LOW,119)));
QD1:=((QD0 / 1) * EMA(CLOSE,20));
QD:=SMA(QD1,5,1);
QF0:=((CLOSE - LLV(LOW,118)) / (HHV(HIGH,118) - LLV(LOW,118)));
QF1:=((QF0 / 1) * EMA(CLOSE,20));
QF:=SMA(QF1,5,1);
PX1:=((((QS + QD) + QF) / 3) + EMA(CLOSE,20));
PX2:=MA(PX1,2);
PX3:=MA(PX1,3);
YY:=((((2 * CLOSE) + HIGH) + LOW) / 4);
MA1:=MA(YY,45);
C1:=(PX1 - MA1);
M:=(PX2 - MA1);
O1:=(PX3 - MA1);
MA2:=MA(C1,8);
BO:=0.5,COLORRED;
DRAWLINE((C1 >= M),C1,(C1 >= M),(O1 - 0.03),COLORRED);
STICKLINE((C1 >= M),M,(O1 - 0.03),COLORRED,0);
DRAWLINE((C1 <= M),C1,(C1 <= M),(O1 + 0.03),COLORBLUE);
STICKLINE((C1 <= M),M,(O1+ 0.03),COLORBLUE,0);
LIFE:=MA(C1,13),COLORGREEN;
A:MA(LLV(C1,120),3),COLORRED;
B:MA(HHV(C1,120),3),COLORGREEN;