文华指标公式--优化MACD


VAR1:=REF(CLOSE,1);
VAR2:=SUM(VOL,2)/((HHV(HIGH,2)-LLV(LOW,2))*100);
VAR3:=(CLOSE-VAR1)*VAR2;
VAR4:=SUM(VAR3,0);
VAR5:=SMA(VAR4,5,1);
VAR6:=SMA(VAR4,8,1);
OSC: VAR5-VAR6;
OSCMA: MA(OSC,4);
OSC, COLORSTICK;
VD: SUM(IF(OSC>0,OSC*1.003,OSC*1.003>0),34)/34;
VE: SUM(IF(OSC<=0,OSC*0.97,OSC*0.97<0),34)/34;

DRAWTEXT(CROSS(OSCMA,VE),OSCMA,'买'),COLORRED;
DRAWTEXT(CROSS(VD,OSCMA),OSCMA,'卖'),COLORGREEN;